xFørŻe
31.05.2021 13:06

Дан массив из 20 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ibrunetochka
16.12.2020 18:50

var

m: array [1..10] of integer;

max, k, i: integer;

begin

for i := 1 to 10 do

read(m[i]);

max := m[1];

k := 1;

for i := 2 to 10 do

if m[i] > max then

begin

k := 1;

max := m[i]

end

else

if m[i] = max then

inc(k);

write(k)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота