kioppo
17.04.2021 10:39

Написать программу на языке Паскаль, которая заполняет массив из n чисел случайными значениями в диапазоне от 0 до 50, затем выводит массив на экран. После - сортирует по неубыванию четные числа этого массива и выводит на экран новый массив

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Авитя1
15.01.2021 14:22

var m,a:array [-100..100] of integer;

n,j,i,count:integer;

begin

write('введите сколько необходимо чисел: ');

read(n);

randomize;

for i:=1 to n do begin

m[i]:=random(51);

write(m[i],' ');

if m[i] mod 2 = 0 then begin

inc(count);

a[count]:=m[i];

end;

end;

writeln;

for i:=1 to count-1 do begin

for j:=1 to count-i do

  if a[j] > a[j+1] then

    swap(a[j+1],a[j]);

 end;

 for i:=1 to count do

   write(a[i],' ');

end.

0,0(0 оценок)
Ответ:
мариатмими
15.01.2021 14:22

var

 N:array of integer;

 A:integer;

begin

 write('Длина массива: '); readln(A);

 setlength(N,A);

 N.FillRandom(0,50);

 writeln('Исходный массив: ',N);

 var X:=N.FindAll(x -> x mod 2 = 0); X.Sort;

 writeln('Полученный массив: ',X);

end.

Примечание:

Не претендую на лучшее решение,просто сделал программу чуть короче)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота