23245086
13.03.2023 03:42

Написать программу нахождения y=x+3,5 x принадлежит[-2; 4]. h=0,5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kurilkodanil
05.06.2023 05:27

1.

const nn=50;
var
a:array [1..nn,1..nn] of integer;
i,j,k,l,n:integer;
begin
writeln('N= ');
readln(n);
for i:=1 to n do
  for j:= 1 to n do
    readln(a[i,j]);
 writeln;
 writeln('Сформированный массив:');
 for i:=1 to n do
 begin
  for j:= 1 to n do
    write(a[i,j],' ');   
  writeln;
end;
writeln;
writeln('Индексы равных элементов:');
for i:=1 to n do
    for j:= 1 to n do
      for k:=i+1 to n do
        for l:= j to n do
        if (a[i,j] = a[k,l]) then writeln('[',i,',',j,'] = [' ,k,',',l,']');
end.

 

2. Недостаточно данных для решения задачи.

0,0(0 оценок)
Ответ:
бэйба123
08.06.2022 16:04

1 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
write('Write a[ ',i,' ] = ');
readln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i] mod 2=0 then writeln(a[i]);
end;
for i:=1 to 5 do
begin
sum:=a[i]+sum;
end;
write('SUMA = ');
writeln(sum);
readln;
end.


2 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
a[i]:= random(46)-10; // random(max-min+1)+min;
end;
for i:=1 to 12 do
begin
if (a[i]>0) then writeln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i]<0 then inc(sum);
end;
write('OTRIC ELEMENTOV = ');
writeln(sum);
readln;
end.

ткань ...

uses crt;
var
days,m:integer;


begin
days:= 30; //дней в месяце
m:=135; //метров сделали за день
writeln('За месяц = ',days*m, ' метров ');
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота