дагмгп
13.06.2021 15:09

нужно составить программу на языке паскаль с использованием оператор выбора CASE. Составить программу, которая бы в зависимости от введенной даты рождения человека в форме «dd.mm.» выводила бы на экран комментарий: если целых лет от 1 до 6 – "дитя", от 7 до 16 – "школьник", от 17 до 22 – "студент" от 23 до 60 – "большой человек", от 60 – "отдыхающий"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ksenya20042
16.12.2022 09:11
Точно должно работать для PascalABC.Net (версия 3.2, сборка 1341).
program Task;
var N,i,kol,sum:integer; //По-хорошему, не integer. Потому что мы работаем с натуральными числами, а не отрицательными
begin
read(N);
for i:=1 to N do 
begin
if (i mod 15)=0 then kol:=kol+1; //15 - это НОК(3,5)
end;
while (N<>0) do
begin
sum:=sum+N mod 10;
N:=N div 10;
end;
writeln('Количество чисел, делящихся и на 3, и на 5, равно ',kol);
writeln('Сумма цифр числа N равна', sum);
end.

Пиши, если что-то не работает или не понятно :)
0,0(0 оценок)
Ответ:
arisha70
06.07.2021 23:32
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
type
    s_b = record
        s_d: array[1..31, 0..9]of integer;
        s_o: array [0..9] of string;
        d_m: array [1..31] of byte;
    end;

var
    r, d: s_b;

begin
    r.s_o[0] := 'еда';
    r.s_o[1] := 'zilie';
    r.s_o[2] := 'oby4';
    d.s_o[1] := 'myz';
    d.s_o[2] := 'zina';
    for var a := 1 to 31 do
        for var b := 0 to 9 do
        begin
            r.s_d[a, b] := 0;
            r.d_m[a] := a;
            d.s_d[a, b] := 0;
            d.d_m[a] := a;
        end;
    
    Println(r);
    Println(d);
end.

покороче, убрано лишнее
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота