rkdkeidkoks61
02.08.2020 21:13

СОСТАВИТЬ БЛОК СХЕМЫ К ЗАДАЧАМ. 1.Составьте программу, которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения.
2.Задано натуральное число a. Является ли оно чётным?
3.Задано натуральное число a. Является ли оно кратным 9?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aiperiwa
09.09.2021 10:34
Сериал повествует о жизни круглых персонажей в стране «Смешариков». У каждого героя свой взгляд на вещи, свои увлечения и яркий характер. Ежедневно герои попадают в неожиданные ситуации или создают их сами.В сериале представлены герои трёх возрастных групп — дети-подростки (Крош, Ёжик, Нюша, Бараш), взрослые (Лосяш, Пин), и пожилые (Кар Карыч, Совунья, Копатыч). Главные герои:

Крош

Ёжик

Нюша

Бараш

Совунья

Кар-Карыч

Пин

Копатыч

Лосяш

Панди

Биби

Ну а если посчитать, всего их 77 (это Группы персонажей

Смешарики: основные персонажи (9)

Смешарики: прочие персонажи (34)

Смешарики: искусственно созданные персонажи (11)

Смешарики: вымышленные персонажи (23))

4.?

0,0(0 оценок)
Ответ:
Vladislava111111111
19.05.2020 12:00
Рассматриваем движение тела, брошенного под углом к горизонту без начального ускорения. Уравнения движения тела в осях координат известны из физики:
\begin {cases} x=v_0t\cdot \cos\alpha \\ \displaystyle y=v_0t\cdot \sin\alpha-\frac{gt^2}{2} \end {cases}
Также известна формула для определения времени движения тела до его падения (т.е. возвращения на исходную высоту, которая совпадает с осью X):
\displaystyle t= \frac{2v_0\sin\alpha}{g}
Считаем, что в начальных условиях задается количество точек, в которых нужно найти значения пути пройденного в осях координат.

uses Crt;
const
   g=9.81;
   pi=3.14;
var
   alpha,ar,v0,t,x,y,tmax,ht,v0x,v0y:real;
   n:integer;
begin
   ClrScr;
   Write('Vvedite alpha, v0: ');
   Read(alpha,v0);
   Write('Chislo tochek= ');
   Read(n);
   ar:=pi*alpha/180;
   v0x:=v0*cos(ar);
   v0y:=v0*sin(ar);
   tmax:=2*v0*sin(ar)/g;
   ht:=tmax/n;
   t:=ht;
   while t<=tmax do
   begin
      x:=v0x*t; y:=v0y*t-g*sqr(t)/2;
      Writeln('t=',t:6:3,' x=',x:8:3,' y=',y:8:3);
      t:=t+ht
   end;
   ReadKey
end.

Тестовое решение:
Vvedite alpha, v0: 45 126.4
Chislo tochek= 10
t= 1.821 x= 162.864 y= 146.461
t= 3.643 x= 325.728 y= 260.375
t= 5.464 x= 488.592 y= 341.742
t= 7.286 x= 651.456 y= 390.562
t= 9.107 x= 814.320 y= 406.836
t=10.929 x= 977.184 y= 390.562
t=12.750 x=1140.048 y= 341.742
t=14.572 x=1302.912 y= 260.375
t=16.393 x=1465.776 y= 146.461
t=18.215 x=1628.640 y=   0.000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота