IIvanMuratov2003
27.10.2020 05:53

с информатикой: Составить программу, включающую меню из четырех пунктов: 1.Создать файл записей (не менее трех), которые содержат два поля (фамилия, оценка). 2.Вывести содержимое файла на экран. 3.Добавить новую запись и упорядочить список по алфавиту. 4.Выход. Первые три пункта меню реализовать в процедурах, которые поместить в модуль.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Бекки5
14.01.2021 14:32

Запись 5 строк в файл }

procedure TForm1.Button1Click(Sender: TObject);

var outfile: TextFile;

begin

AssignFile(outfile, 'outfile.txt')

;Rewrite(outfile);

writeln(outfile, 'Привет из Delphi');

writeln(outfile, 'Моя программа работает, и выводит '

+'данный текст, чтобы доказать это...');

writeln(outfile, '3. Треться строка');

writeln(outfile, '234 четвертая');

writeln(outfile, 'Пятая строка');

CloseFile(outfile);

end;

// вывод на экран точнее в мемо или лист бокс

procedure TForm1.Button2Click(Sender: TObject);

begin

// выводим в мемо

Memo1.Lines.LoadFromFile('outfile.txt');

// либо в лист бокс как тебе лучше

ListBox1.Items.LoadFromFile('outfile.txt');

end;

// кнопка для закрытия

procedure TForm1.Button3Click(Sender: TObject);

begin

Close;

end;

// событие onClose

procedure TForm1.FormClose(Sender: TObject; var CloseAction: TCloseAction);

begin

if MessageDlg('Вы точно хотите выйти?', mtConfirmation, mbOkCancel,0)= mrOk then begin

CloseAction:= caFree;

end

else begin

CloseAction:= caNone;

end;

end;

ЗДЕСЬ!

outfile.txt - это ваш файл(может создаваться автоматически

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота