zakharakobinetowxuit
14.04.2021 06:38

Напишите программу на чистом С для этой задачи: Задан массив целых чисел из 22 элементов и некоторое целое число target. Найти все пары элементов массива, произведение которых равно числу target. Вывести на консоль индексы и значения найденных пар.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Maruua1
01.04.2020 15:14
// PascalABC.NET 3.2, сборка 1403 от 16.03.2017
// Внимание! Если программа не работает, обновите версию!

function SumDigits(n:integer):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;

begin
  var s:=ReadArrInteger('Вводите:',3).Select(x->SumDigits(x)).ToArray;
  var i:=s.IndexMax;
  var k:=s.Where(x->x=s[i]).Count;
  case k of
    1:begin
      Write('Сумма цифр наибольшая у ');
      case i of
        0:Write('первого');
        1:Write('второго');
        2:Write('третьего');
        end;
      Writeln(' числа')
      end;
    2:begin
      Write('Сумма цифр наибольшая у ');
      if s[0]=s[1] then Writeln('первого и второго чисел')
      else
        if s[0]=s[2] then Writeln('первого и третьего чисел')
        else Writeln('второго и третьего чисел')
      end;
    3:Writeln('Суммы цифр у всех трех чисел равны')
    end
end.

Примеры
Вводите: 102030 324 19
Сумма цифр наибольшая у третьего числа

Вводите: 16453 4320 56341
Сумма цифр наибольшая у первого и третьего чисел

Вводите: 12345 12354 54321
Суммы цифр у всех трех чисел равны
0,0(0 оценок)
Ответ:
пир14
21.09.2020 11:35

1.V=24*2=48 байт = 384 бита

2.192 символа на стр- 30720 символов. Мощность алфавита 256 - значит в алфававите 256 знаков. 2 в степени восемь - равно 256.весь алфавит можно закодировать одним байтом (в одном байте - как раз восемь бит, степень двойки. Бит - принимает ДВА значения - 0 и 1 - отсюда основание 2, которое возводим в восемь :) ) на каждый символ текста надо потратить один байт памяти. Итого получаем 30720 БАЙТ. в одном КИЛОБАЙТЕ 1024 байта. Делим 30720 на 1024 получаем 30 КБайт.

3.в 2 раза уменьшился

4

1024000/8=128000 (перевели в байты) 

128000/1024=125кбайт/сек (перевели в килобайты) 

125*5= 625 килобайт

5.

всего используется 12 букв + 10 цифр = 22 символа 

для кодирования 22 вариантов необходимо использовать 5 бит, так как , т.е. 4 бит не хватит (они позволяют кодировать только 16 вариантов), а 5 уже достаточно 

таким образом, на каждый символ нужно 5 бит (минимально возможное количество бит) 

полный номер содержит 6 символов, каждый по 5 бит, 30 бит один номер. 

по условию каждый номер кодируется целым числом байт (в каждом байте – 8 бит), поэтому требуется 5 байт на номер ( ), 4 байтов не хватает, а 5 – минимально возможное количество 

на 32 номеров нужно выделить 160 байтов приблизительно 192байта 

правильный ответ – 160байт...т.к 32*5=160 или приблизетельно 192байта.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота