sanya3202
05.10.2022 14:47

(на паскале) Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 8. Программа
получает на вход количество чисел в последовательности, а затем сами
числа.
Количество чисел не превышает 1000. Введённые числа по модулю
не превышают 30 000.
Программа должна вывести одно число: количество чисел, кратных 6
и оканчивающихся на 8. ( ещё хотелось бы объяснение что вообще от меня надо в этом задание, то есть что должно получиться типо как работает программа вообще )


(на паскале) Напишите программу, которая в последовательности натуральных чисел определяет количеств

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gamlet2008
14.01.2021 10:50

var

a, s: integer;

begin

s:= 0;

readln(a);

while a<>0 do begin

if (a mod 3 = 0) and (a mod 10 = 8) then

s := s + a;

readln(a);

end;

writeln(s)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота