katerinaplachet
31.08.2022 07:27

найти ошибку в коде для программы код паскаля У вас на столе лежит N монет. Некоторые из них лежат вверх решкой, а
некоторые - гербом. Определите минимальное число монет, которые нужно
перевернуть, чтобы все монеты были повернуты вверх одной и той же стороной.

program coins;
var
n,i,s,a:longint;
begin
readln(n);
for i:=1 to n do
begin
readln(a);
if a=0 then
s:=s+1
end;
writeln(s);
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
akowa05
15.12.2022 09:35

Выбор будущей профессии — это очень важный шаг в жизни каждого человека. Некоторые выпускники школ долго сомневаются, так как им трудно определиться, другие же наоборот принимают твердое решение раньше. Для того чтобы стать тем, кем хочешь нужно сначала выучиться и получить образование. Если будущая профессия очень нравиться тогда и учиться будет интересно и не трудно.

Что касается меня, то я хочу стать программистом. Эта профессия привлекла меня, когда я учился в младших классах. Тогда мы начали изучать информатику, которая стала моим любимым предметом. Я всегда очень внимательно слушаю учительницу. Мне интересны абсолютно все темы по этому предмету, поэтому я часто задаю много дополнительных вопросов на уроках. Дома у меня есть много разных книг: о строении компьютера, о работе с разными программами, об основах программирования, о поломках, о вирусах и другие. Кроме того, я обычно читаю дополнительную литературу по информатике в нашей школьной библиотеке или ищу интересующую меня информацию в интернете.

0,0(0 оценок)
Ответ:
евгения406
14.07.2021 04:19

Задача по расчету объемов информации.

Итак 1.5 Кб передаются за 210 секунд.  Переведем 1.5 Кб в байты 1кб=1024 байт

1.5 умножим на 1024 = 1536 байт.

Рассчитаем пропускную канала связи.

Для этого разделим объем на время.

1536/210

теперь

Узнаем скорость передачи второго файла.

Объем 512 байт, будет передаваться 512/(1536/210)=70 секунд.


Можно пойти другим путем и увидеть, что 512 это ровно в три раза меньше чем 1.5 кб и тогда понятно что файл, который имеет в три раза меньший размер будет передаваться в три раза быстрее, значит 210/3=70 секунд



70 секунд. 512/(1,5*1024/210)=70

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота