kosahevaluba
11.05.2023 14:20

Написать программу для робота "закрасить периметр квадрата через клетку" длина сторон не известна, кумир.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
marimitul
06.12.2020 17:49
Треугольник существует, если сумма длин двух любых его сторон больше длины третьей стороны.
Длина стороны может быть определена как расстояние между соответствующими сторонами треугольника:
\displaystyle L_{AB}=\sqrt{(x_B-x_A)^2+(y_B-y_A)^2

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
type
  Point=record
  x,y:real
  end;

procedure GetPoint(c:char;var M:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Read(M.x,M.y)
end;

function Dist(a,b:Point):=sqrt(sqr(b.x-a.x)+sqr(b.y-a.y));

begin
  var A,B,C:Point;
  GetPoint('A',A); GetPoint('B',B); GetPoint('C',C);
  var ab:=Dist(A,B);
  var bc:=Dist(B,C);
  var ac:=Dist(A,C);
  if (ab<bc+ac) and (bc<ab+ac) and (ac<ab+bc) then
    Writeln('Треугольник существует')
  else Writeln('Треугольник не существует')
end.

Тестовое решение:
Введите координаты точки A: -6.9 -5.3
Введите координаты точки B: 0 11.4
Введите координаты точки C: 9 3
Треугольник существует
0,0(0 оценок)
Ответ:
KasiaW
11.11.2022 08:33
//Pascal ABC.NET v3.0 сборка 1111

Const
 s=5;

Var
 ar:array[1..s] of integer;
 n,m,i:integer;
begin
 writeln('N');
 readln(n);
 writeln('M');
 readln(m);
 writeln('Array:');
 for i:=1 to s do
   readln(ar[i]);
 writeln('First array:');
 for i:=1 to s do
  begin
   write(ar[i]:4);
   if ar[i] div n<>0 then ar[i]:=ar[i]+m;
  end;
 writeln;
 writeln('Final array:');
  for i:=1 to s do
   write(ar[i]:4);
end. 

Пример ввода:
3
3
1
2
3
4
5
Пример вывода:
First array:
   1   2   3   4   5
Final array:
   1   2   6   7   8

//Блок-схема во вложении
Ввести двумерный массив a. все элементы, которые при целочисленном делении на n ненулевое значение,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота