MARCOM03
19.11.2020 13:02

Очень нужнее ответ Решение нужно на любом языке программирования, только в ответе запишите на каком языке программирования вы дали ответ


Очень нужнее ответ Решение нужно на любом языке программирования, только в ответе запишите на каком

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vishnya39
22.09.2022 16:10
1.
var i,N,c: integer;

var a: array of integer;

var b: array of integer;

begin

c:=0;

readln(N);

Setlength(a,N);

setlength(b,N);

for i:=0 to a.Length-1 do

begin

readln(a[i]);

if a[i] >0 then

begin

b[c]:=a[i];

c:=c+1;

end;

end;

Setlength(b,c);

write(b);

end.

2.

var N,M: integer;

type a = array of array of integer;

var matr: a;

function CreateMatrix(N,M: integer): a;

begin

  SetLength(Result,N);

  for var i:=0 to N-1 do

    SetLength(Result[i],M);

end;

procedure FillMatrByRead(matr: a);

begin

  for var i:=0 to matr.Length-1 do

  for var j:=0 to matr[0].Length-1 do

    readln(matr[i,j]); 

end;

procedure WriteMatrix(matr: a);

begin

  for var i := 0 to matr.Length-1 do

  begin

    for var j := 0 to matr[0].Length-1 do

      write(matr[i,j]:3);

    writeln;

  end;

end;

procedure MatrixZero(matr: a);

begin

  for var i := 0 to matr.Length-1 do

  begin

    for var j := 0 to matr[0].Length-1 do

      if (matr[i,j] = 0) then

      write('matr','[',i,',',j,']');

    writeln;

  end; 

end;

begin

readln(N,M);

matr:= CreateMatrix(N,M);

FillMatrByRead(matr);

WriteMatrix(matr);

MatrixZero(matr);
end.
0,0(0 оценок)
Ответ:
АнютаАс
09.05.2023 16:10
Наступает век современных технологий. Например, книгу, которую раньше мы должны были искать в магазине или библиотеке, теперь можно легко найти в Интернете. Ниже будут приводиться сравнения между книгой (и прочими "бумажными" ресурсами) и электронной страницей:
- Чтобы потерять книгу, достаточно просто где-нибудь её забыть. В троллейбусе, в гостях, на работе. А может, вы уронили её в лужу? Вряд ли после такого получится восстановить её содержимое и читать её с прежним удовольствием. При той же ситуации с электронными образовательными ресурсами (далее ЭОР) можно просто скачать копию страницы уже на новое устройство и продолжить изучение. Если речь идёт о каком-то онлайн обучении, то тут всё ещё проще.
- Использование ЭОР вместо печатных изданий выгоднее в плане экологии. Чисто в перспективе, чем больше людей будет предпочитать ЭОР обычным книгам, тем меньше будет спрос на эти книги. А значит, меньше поводов вырубить лишнее дерево.
- В большинстве случаев ЭОР обновляется гораздо чаще, нежели энциклопедии. Руководствуясь Интернетом, мы будем получать гораздо больше свежих и актуальных знаний, нежели читая только книги. Очевидно, несколько часов, проведённых в Интернете на образовательных сайтах, дадут человеку больше знаний, чем наши прапрадеды копили всю жизнь.
- Доступно. Большинство курсов абсолютно бесплатны, причём зачастую из них можно получить больше знаний, чем из обычной книги.

Вывод: Сегодня всё больше и больше людей находят, что электронные версии текста лучше бумажных. Тем не менее, не стоит забывать, благодаря чему наши предки подарили нам Всемирную паутину.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота