хорошист536
11.04.2021 23:25

Переведите из паскаля в питон program naselenie; var
р: array [1..10] of real;
n: array [1..10] of string;
i, j, imin: integer;
х: real;
r: string;
const
k: array [1..10] of real = (58100, 81200, 10300, 5190, 39100, 57200, 38500, 9800, 5060, 57800);
s: array [1..10] of real = (244.1, 357, 132, 43.1, 504.8, 301.2, 312.7, 92.0, 337, 551);
begin
n[1]:=’Великобритания’;
n[2]:=’Германия’;
n[3]:=’Греция’;
n[4]:=’Дания’;
n[5]:=’Испания’;
n[6]:=’Италия’;
n[7]:=’Польша’;
n[8]:=’Португалия’;
n[9]:=’Финляндия’;
n[10]:=’Франция’;
for i:=1 to 10 do
р[i]:=k[i]/s[i];
for i:=1 to 9 do
begin
imin:=i;
for j:=i+1 to 10 do
if p[j]<p[imin] then
imin:=j; x:=p[i];
р[i]:=р[imin];
p[imin]:=х;
r:=n[i];
n[i]:=n[imin];
n[imin]:=r;
end;
writeln (‘Отсортированная информация’);
for i:=1 to 10 do
writeln (n[i], ‘ — ‘, p[i]);
end.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
qqruzko
28.01.2023 15:48
Высказывание А:
"За любой партой сидит ученик, решивший контрольную работу наполовину".
Высказывание В:
"Не менее половины класса решило контрольную работу полностью".
Логическая функция F, определяющая понятие "Легкая контрольная работа", может быть записана в виде A \land B
Высказывание, что работа не является легкой, есть инверсия функции F.
\bar F=\overline{A \land B}=\bar A \lor \bar B
Сформулируем инверсию высказывания А:
"Хотя бы за одной партой сидит ученик, не решивший контрольную работу наполовину".
Сформулируем инверсию высказывания В:
"Менее половины класса решило контрольную работу полностью".
Тогда инверсия F может быть записана в следующем виде:
Хотя бы за одной партой сидит ученик, не решивший контрольную работу наполовину ИЛИ менее половины класса решило контрольную работу полностью.
0,0(0 оценок)
Ответ:
lizahelp7
09.07.2020 01:11
Можно печатать машины                                                                        ну, для начала, стоит упомянуть, что с ее можно печатать машины! создатели последнего фильма о бонде, скайфол, наняли компанию voxeljet, которая специализируется на 3d-печати, для создания трех моделей престижной машины астон мартин db5 масштабом 1: 3 для съемок аварий. но не расстраивайтесь, одна из них уцелела и позднее была продана на аукционе кристис почти за 100 000 фунтов стерлингов.                                                                                      корпуса для мобильных устройств                                                меньше размером, но не менее роскошная, первая в мире модель корпуса nokia lumia 820 была отпечатана мастерами 3d-печати, в компании makerbot. меньше чем за день после того, как были переданы в работу спецификации, специалисты компании при 3d-магии создали эту модель.протезированиеиндустрия медицинского оборудования - один из крупнейших рынков в мире 3d-печати. нужен бедренный сустав? распечатаем! рынок протезирования просто влюблен в 3d-технологию. специалисты бельгийской компании biomedics недавно имплантировали распечатанную на 3d-принтере титановую челюсть 83-летней пациентке. и это только начало! детали машинподполковник авиации энди грин намерен побить рекорд скорости на суше, пилотируя сверхзвуковой автомобиль bloodhound ssc, способный развивать скорость свыше 1600 км/час - автомобиль с внутренностями, выполненными на 3d-принтере. при системы автоматизированного проектирования и глиняного слепка руки грина, титановое рулевое колесо было отпечатано максимально удобным для рук бесстрашного гонщика. на старт, нашему удивлению мы узнали, что еще 3d-принтеры можно использовать в сочетании со сканами системы автоматизированного проектирования для распечатывания клона опухоли перед операцией, с тем чтобы хирурги точно знали, с чем именно им придется иметь дело. удобно! предметыученые из уорикского университета сообщили, что электронная схема может быть неотъемлемой частью 3d-напечатанных предметов, и чтобы доказать это, они изобрели материал, который называли carbomorph, а затем использовали его для создания компьютерного игрового устройства и кружки, которая знает, когда она наполнена.космоснаса и исследователи вашингтонского государственного университета работают над 3d-печатью лунной пылью. с этой технологией мы могли бы в будущем рассматривать возможность изготовления лунной базы непосредственно на месте, целиком из материалов доступных на луне. в то же время космонавты могли бы использовать эту технологию для починки и замены сломанного оборудования. хьюстон, есть идея! почтаполагаете, что посылки идут слишком медленно? файлообменник pirate bay недавно открыл новый раздел на своем сайте под названием "physibles", для того, что они описывают как "объекты данных, которые могут стать осязаемыми". другими словами, достаточно загрузить свои 3d-чертежи, и любой, кто получит этот файл сможет распечатать реальный предмет. вот это называется делиться! компьютерные героино будьте осторожны: несколько любителей компьютерных игр нажили неприятности с законом когда стали использовать свои принтеры для воспроизводства фигурок из warhammer 40000. games workshop - создатели warhammer - быстро вмешались в их деятельность, волнуясь о своих правах на патенты. похоже, что следующей битвой на поле авторских прав на цифровые изделия будет борьба за видите, 3d-печать уже преподносит нам не мало сюрпризов, но, очевидно, самое интересное еще впереди. а если бы вы были ограничены лишь вашим воображением, что бы вы напечатали в первую очередь?
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота