danayamirnaya
16.09.2022 16:27

составить программу на языке паскаль. Составить программу, которая бы в зависимости от введенной даты рождения человека в форме «dd.mm.» выводила бы на экран комментарий: если целых лет от 1 до 6 – "дитя", от 7 до 16 – "школьник", от 17 до 22 – "студент" от 23 до 60 – "большой человек", от 60 – "отдыхающий"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
софи157
30.12.2022 10:01
Последовательность действий ученика при самостоятельном изучении параграфа учебника:
1) достать учебник
2) сесть за стол
3) открыть учебник
4) прочитать параграф
5) ответить на вопросы после параграфа
6) открыть тетрадь
7) сделать краткий конспект по вопросам в конце параграфа
8) закрыть тетрадь
9) закрыть учебник
10) убрать учебник

Последовательность действий мамы при варке манной каши:
1) взять кастрюлю
2) налить воду в кастрюлю
3) зажечь огонь на плите
4) поставить кастрюлю на огонь
5) достать крупу, молоко
6) добавить в кастрюлю молоко
7) когда вода и молоко закипят добавить крупу
8) взять ложку
9) мешать ложкой крупу
10) накрыть крышкой
11) выключить огонь под кастрюлей
0,0(0 оценок)
Ответ:
разетка1234
19.09.2021 00:53

#include <iostream>

#include <vector>

using namespace std;

int am_dig(int k){

   int res = 0;

   while(k > 0){

       res++;

       k /= 10;

   }

   return res;

}

double average(vector<double> a){

   double sum = 0;

   for(auto i: a)

       sum += i;

   return sum/a.size();

}

int main() {

   vector<double> a;

   double x = 1;

   while(x != 0){

       cin >> x;

       if(am_dig(x) == 3)

           a.push_back(x);

   }

   if(a.size() == 0)

       cout << "NO";

   else

       cout << average(a);

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота