Мята04
06.11.2020 08:58

Напишите программу которая выводит число кратное 5.Python 1)30
True
2)27
False
за првильный ответ
ответ писать в сайте repl.it
python​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KattyDark010203
13.01.2021 08:21

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

print(m)

Объяснение:

Объявим переменную m, где мы будем хранить ответ, равную 0 (так как в задании представлены натуральные числа, а 0 является ближайшим ненатуральным), и запишем ее в начало программы.Теперь можем работать с переменной k. Если остаток от деления на 5 равен 0 (т.е. кратно 5) и значение k больше значения m (т.к. m — наш ответ), то присвоим значение из переменной k переменной m.И в самом конце выводим переменную m — наш ответ.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота