Serzhantiko
27.10.2022 20:13

Составить программу на С++ Создайте массив из 10 ячеек числа введите на клавиатуре от 1 до 10.Выполняя сортировку выбором.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Zhaksyldi
11.01.2021 21:16

#include <iostream>

using namespace std;

int main() {

int a[10],size=10,min,temp;

for (int i = 0; i < 10; i++) {

 cin >> a[i];

}

 

for (int i = 0; i < size - 1; i++) {

 min = i;

 for (int j = i + 1; j < size; j++) {

  if (a[j] < a[min]) {

   min = j;

  }

  temp = a[i];

  a[i] = a[min];

  a[min] = temp;

 }

}

for (int i = 0; i < 10; i++) {

 cout << a[i] << " ";

}

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота