gregoryan2001
18.06.2022 21:47

Заполнить массив из элементов случайными числами в интервале [-15..15] и найти в нем максимальный и минимальный элементы и их номера. Язык паскаль Написать программу.

1. Число элементов массива задаете индивидуально.

2.Перед выводом массива вывести на экран, что надо найти в задаче и характеристики массива.

3. Вывод результата согласно примеру.

4. Добавить комментарий к каждой строке программы.

Пример:

Исходный массив:

4 -5 3 10 -4 -6 8 -10 1 0

максимальный a[4]=10

минимальный a[8]=-10

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ssyyppeerrmmaax
09.11.2022 05:36
//PascalABC.NET 3.2 сборка 1318

var
  l, r, counter, i: integer;

function DifNum(a: integer): integer;
var  se: set of integer;
  i: integer;
begin
  while a > 0 do
  begin
    if a mod 10 in se then
    begin
      DifNum := 0;
      exit;
    end
    else include(se, a mod 10);
    a := a div 10;
  end;
  DifNum := 1;
end;

begin
  read(l, r);
  for i := l to r do
    counter += DifNum(i);
  writeln(counter);
end.

//Альтернативное решение на Паскале

Var
  l,r:integer;
begin
read(l,r);
writeln(range(l,r).where(x -> x.tostring.toarray.distinct.count=length(x.tostring)).Count);
end.

//Dev-C++ 5.11 (C)

#include <stdio.h>
#include <malloc.h>

int DifNum(int);

int main(void)
 {int l,r,counter=0;
 scanf("%d %d",&l,&r);
 for(int i=l;i<=r;i++)
  counter+=DifNum(i);
 printf("%d",counter);
return 0;}

int DifNum(int a)
 {int k=1,*nums;
 nums=(int*)malloc(k*sizeof(int));
 nums[0]=-1;
 while(a>0)
  {for(int i=0;i<k;i++)
   if(a%10==nums[i])
    return 0;
  k++;
  nums=(int*)malloc(k*sizeof(int));
  nums[k-1]=a%10;
  a/=10;}
 free(nums);
 return 1;}

Пример ввода:
1 12
Пример вывода:
11
0,0(0 оценок)
Ответ:
gatshow029
13.03.2020 05:49
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

function MaxSubstr(s1,s2:string):string;
begin
  var a:=new integer[s1.Length+1,s2.Length+1];
  var u:=0; var v:=0;
  for var i:=0 to s1.Length-1 do
    for var j:=0 to s2.Length-1 do
      if s1[i+1]=s2[j+1] then begin
        a[i+1,j+1]:=a[i,j]+1;
        if a[i+1,j+1]>a[u,v] then begin u:=i+1; v:=j+1 end
        end;
  Result:=s1.Substring(u-a[u,v],a[u,v])
end;

begin
  var s:='trapperkaperkatrter';
  var t:='appekaperspamer';
  Writeln(MaxSubstr(s,t))
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота