ahgdy
08.10.2020 02:16

Цикл for питон Даны два целых числа, причем неизвестно, какое из них больше. Вывести на экран все числа от первого до второго, включая границы промежутка.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
StrangeLis
23.12.2020 16:26
Даю пример на c#, авось придумать код на паскале, т.к сам онли в c#:
int perva, pervb, pervv;
int vtora, vtorb, vtorv;
Console.WriteLine("Введите длину первого ящика");
perva = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину первого ящика");
pervb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту первого ящика");
pervv = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите длину второго ящика");
vtora = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину второго ящика");
vtorb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту второго ящика");
vtorv = Convert.ToInt32(Console.ReadLine());
int result;
int result2;
result = perva * pervb * pervv;
result2 = vtora * vtorb * vtorv;
obratno:
if (result > result2)
{
int anotherresult;
anotherresult = result2 * 2;
goto obratno;
}
if (result < result2)
{
int anotherresult2;
anotherresult2 = result * 2;
goto obratno;
}
0,0(0 оценок)
Ответ:
Olesya15551
23.12.2020 16:26

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота