кика20051
09.05.2023 09:00

№1. Составить программу, которая определяет номер строки и столбца элемента двумерного массива, значение которого больше 0, но меньше 2. Заполнить массив целыми случайными числами из диапазона от 0 до 30. №2. Составить программу, которая вычисляет количество положительных чисел среди 10 чисел, которые вводятся с клавиатуры.Выполнить 2 задания на языке C++ и на языке Python.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Margarita12071
11.03.2022 23:20
1) var a,b,x:real;
begin
write ('введите числа а и b: '); readln(a,b);
x:=-b/a;
writeln('x= ',x);
end.
2) var r1,r2,s:real;
begin
write ('введите размеры внешнего и внутреннего радиусов: '); read(r1,r2);
s:=pi*r1*r1-pi*r2*r2;
write ('Площадь кольца = ',s);
end.
3) var a,b,c,s,p:real;
begin
write ('введите длины катетов: '); read(a,b);
s:=a*b/2;
c:=sqrt(a*a+b*b);
p:=a+b+c;
write ('Площадь треугольника = ',s);
write ('Периметр треугольника = ',p);
end.
4)  var a,b,sr:real;
begin
write ('введите числа а и b: '); readln(a,b);
sr:=(abs(a)+abs(b))/2;
writeln('среднее арифметическое модулей = ',sr );
end.

5) var x1,y1,x2,y2,r:real;
begin
write ('введите координаты точек: '); readln(x1,y1,x2,y2 );
r:=sqrt ( sqr(x2-x1)+sqr (y2-y1));
writeln('расстояние = ',r );
end.
6)  var a,b,h, s, p:real;
begin
write ('введите длины оснований и высоту трапеции: '); readln(a,b,h);
s:=(a+b)*h/2;
p:=a+b+h+sqrt (sqr(abs(a-b))+h*h);
write ('Площадь трапеции = ',s);
write ('Периметр трапеции= ',p);
end.
7) var a,e,d,s, p:integer;
begin
write ('введите трехзначное число: '); readln(a);
e:=a mod 10; s:=a div 100;
d:= (a div 10) mod 10; p:=e*d*s;
write ('разность между трехзначным числом и его произведением = ',a-p);
end.
 к твоему комментарию 
var x,s,m,c: integer;
begin
write('введите количество секунд: ');readln(x);
c:=x div 3600;
m:= (x mod 3600) div 60;
s:=(x mod 3600) mod 60;
часов ',m,' минут ', s,' секунд ');
end.
0,0(0 оценок)
Ответ:
Ренчик223
13.03.2020 03:58
∨ — логическое или, 0 будет только в случае 0 ∨ 0, в остальных случаях 1.
& — логическое и, 1 будет только в случае 1 & 1, в остальных случаях 0.
Если нет скобок, сначала выполняется &, потом ∨.

1) (1 ∨ 1) ∨ (1 ∨ 0) = 1 ∨ 1 = 1
2) ((1 ∨ 0) ∨ 1) ∨ 1 = (1 ∨ 1) ∨ 1 = 1 ∨ 1 = 1
3) (0 & 1) & 1 = 0 & 1 = 0
4) 1 & (1 & 1) & 1 = 1 &  1 & 1 = 1
5) ((1 ∨ 0) & (1 & 1)) & (0 ∨ 1) = (1 & 1) & 1 = 1 & 1 = 1
6) ((1 & 1) ∨ 0) & (0 ∨ 1) = (1 ∨ 0) & 1 = 1 & 1 = 1
7) ((0 & 0) ∨ 0) & (1 ∨ 1) = (0 ∨ 0) & 1 = 0 & 1 = 0
8) (A ∨ 1) ∨ (B ∨ 0) = 1 ∨ B = 1
9) ((1 & A) ∨ (B & 0)) ∨ 1 = (A ∨ 0) ∨ 1 = A ∨ 1 = 1
10) 1 ∨ A & 0 = 1 ∨ (A & 0) = 1 ∨ 0 = 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота