dianasadykovaaaa
21.03.2020 12:24

Написать программу(на abc pascal), которая находит сумму четных цифр в введенном с клавиатуры натуральном числе меньше 30000)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sashagorchakova
13.06.2020 04:13

Program Zn;
var n,k,sum:integer;
Begin
Writeln('Введите натуральное число');
Readln(n);
While n<>0 do begin
k:= n mod 10;
if k mod 2 = 0 then sum:=sum+k;
n:= n div 10;
end;
writeln('Сумма четных чисел  = ', sum);
end.

(Проверено и откомпелировано на Pascal.NET)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота