Bogdan300707
24.11.2022 14:03

Написать программу на языке С++ для создания динамического массива A[N] , заполнить массив с генератора случайных чисел (получение случайного числа в интервале [a,b] оформить как функцию (а=-30,b =30)). Полученный массив перезаписать удалив из него все нечетные числа.
Перезапись оформить как функцию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Mariya050
26.05.2020 23:29

матрица заполняется случайно

программа на pascalabc

Var

max,min,mina,minb,maxa,maxb,a,b,c: integer;

mas: array[1..3,1..3] Of integer;

Begin

writeln('до :');

For a:=1 To 3 Do

For b:=1 To 3 Do

Begin

mas[a,b] := random(100);

If mas[a,b]>max Then

Begin

max := mas[a,b];

maxa := a;

maxb := b;

End;

If (min=0)Or(mas[a,b]<min) Then

Begin

min := mas[a,b];

mina := a;

minb := b;

End;

write(mas[a,b],' ');

End;

c := mas[maxa,maxb];

mas[maxa,maxb] := mas[mina,minb];

mas[mina,minb] := c;

writeln;

writeln('после :');

For a:=1 To 3 Do

For b:=1 To 3 Do

write(mas[a,b],' ');

0,0(0 оценок)
Ответ:
Eazyeazy
26.05.2020 23:29

Var a:array [0..2,0..2] of integer;

Position:array[0..1,0..1] of byte;

i,j,max,min:integer;

Procedure print(a:array of array of integer);

Begin

For i:integer:=low(a) to high(a) do begin

For j:integer:=low(a[i]) to high (a[i]) do

Write(a[i,j],' ');

Writeln;

End;

End;

Begin

Max:=integer.minvalue;

min:=integer.maxvalue;

for i:=low(a) to high(a) do

For j:=low(a[i]) to high(a[i]) do

A[i,j]:=random(10);

Print(a);

for i:=low(a) to high(a) do

For j:=low(a[i]) to high(a[i]) do

Begin

If (a[i,j]<min) then begin

Min:=a[i,j]; position [0,0]:=i; position [0,1]:=j;

End;

If (a[i,j]>max) then begin

Max:=a[i,j]; position [1,0]:=i; position [1,1]:=j;

End;

End;

Swap(a[position[0,0], position [0,1]],a[position [1,0]],a[position [1,1]]);

Print(a);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота