polinapetrova8
22.10.2020 11:21

Напишите программу, которая преобразует строчные буквы в заглавные, используя байтовые операции. Для работы используйте XOR - XOR Ry,Rx – «исключающее ИЛИ» (чтобы исключить код 20)
Блок данных может выглядеть так:
D:
DATA «abcdefgh»

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Snoowker
20.03.2021 15:31

Создаем в Excel VBA две пользовательские функции:

Function newstr(str As String, n As Integer) As String

Dim i As Integer

For i = 1 To n

str = Replace(str, "a", "ab")

str = Replace(str, "bb", "c")

Next

newstr = str

End Function

Function chrcount(str1 As String, str2 As String) As Integer

Dim str() As String

str = Split(str1, str2)

chrcount = UBound(str, 1)

End Function

В ячейку рабочего листа вставляем формулу:

= chrcount(newstr("abab"; 333); "a")&","&chrcount(newstr("abab"; 333); "b")&","&chrcount(newstr("abab"; 333); "c")

Получаем результат:

2,0,334

0,0(0 оценок)
Ответ:
Hrachuk
28.03.2020 07:09
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота