Напишите программу, которая выводит на экран N случайных целых чисел и находит их сумму, произведение, среднее арифметическое всех чисел и значение квадратного корня из суммы всех чисел. (N вводит пользователь) используете только цикл с параметром
Uses crt; var item, rub, doll: real; job: integer; begin writeln('Введите курс ру по отношению к дол: '); read(item);//Вводим курс рубль-доллар writeln('Перевести из (рубля в доллар(2)) или (доллар в рубль(1))?'); read(job);//Вводим режим case job of 2: begin writeln('Введите кол-во рублей: '); read(rub);//Вводим рубль rub := rub / item; writeln('doll = ',rub); end; 1: begin writeln('Введите кол- во долларов: '); read(doll);//Вводим доллар doll := doll * item; writeln('rub = ',doll); end; end; end.
Я ответил, но ответ почему-то не сохранился. 1) Минимально в компьютер входят: системный блок, клавиатура и монитор. Мышь, принтер и сканер не входят! Во времена MS-DOS работали без мышей, принтер подключали редко, а сканеров тогда вообще не было.
2) В системный блок входят материнская плата, на ней процессор, память, микросхема BIOS. В слоты вставляются видеокарта и звуковая карта. Хотя в последнее время видео и звук ставят сразу на материнскую плату, но они обычно плохого качества, нормальные нужно ставить в слоты отдельно. На шлейфах подключаются винчестер и CD/DVD дисковод. Иногда Blue-Ray, но это пока редкость. Раньше еще были дисководы для дискет, 5,25 дюймов и 3,5 дюйма, последние еще иногда встречаются. В сервере даже видеокарта и монитор не нужны.
3) Контроллер - это микросхема, плата или даже программа, которая управляет какой-то периферией, например, видео, звуком или сканером.
4) Физически устройства соединяются через слоты, раньше были ISA и VLB, сейчас PCI, PCI-Express, SCSI и другие. А также через шлейфы или просто по проводам.
5) Информация по шине попадает на нужное устройство благодаря шине адреса, в которой заложено, куда эта информация должна прийти.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку