ученик1443
31.03.2022 17:51

1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным образом в диапазоне от 10 до 80. Написать программу, которая считает количество элементов массива, значение которых больше 50.

2. Дан массив целых чисел, состоящий из 20 элементов. Значение элементов массива задаются случайным образом в диапазоне от 50 до 150. Написать программу, которая считает количество элементов массива, значение которых меньше 100.

На паскале. Сделайте так чтобы выполнялось

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
crazzylolipoop
09.01.2021 12:03

Если не видно на скриншоте  (Я правильно понял,как нужно сделать?)

1)

Program v1;

var a:array[1..15]of integer;            

i,n,kol:integer;

begin          

randomize;

for i:=1 to 15 do a[i]:=random(70)+10;                            

write('Значение матрицы: ');                                      

for i:=1 to 15 do write(a[i]:5); writeln;  

kol:=0;

 for i:=1 to 15 do

   if a[i]>50 then kol:=kol+1;

 writeln(kol);

 end.

   2)

Program v1;

var a:array[1..20]of integer;            

i,n,kol:integer;

begin            

randomize;

for i:=1 to 20 do a[i]:=random(100)+50;                            

write('Значение матрицы: ');                                      

for i:=1 to 20 do write(a[i]:5); writeln;  

kol:=0;

 for i:=1 to 20 do

   if a[i]<100 then kol:=kol+1;

 writeln('Количество элементов массива, значение которых меньше 100: ',kol);

 end.

   

   


1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
0,0(0 оценок)
Ответ:
Hava991111
09.01.2021 12:03

##

// #1

var a := ArrRandom(15, 10, 80);

a.Println.Count(t -> t > 50).Println;

// #2

var b := ArrRandom(20, 50, 150);

b.Println.Count(t -> t < 100).Println


1. Дан массив целых чисел, состоящий из 15 элементов. Значение элементов массива задаются случайным
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота