Yarik200825
13.01.2022 07:38

1. дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 – рост учащихся выпускного класса. в баскетбольную команду берут тех, чей рост не менее 180 см. напишите программу, которая подсчитывает число претендентов в состав баскетбольной команды и выводит номера подходящих кандидатур.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
averdarya
13.06.2020 02:37

Program Zn;
var m:array[1..30] of byte;
c,i:integer;
Begin
for i:=1 to 30 do begin
writeln('Введите рост кандидата');
Readln(m[i]);
if m[i]>=180 then inc(c)
end;
writeln('Количество подходящих кандидатур: ',c);
end.

(Программа проверена и откомпелирована на Pascal.NET, если есть вопросы, пишите)

 

 

0,0(0 оценок)
Ответ:
GeBorgge
13.06.2020 02:37

const

  n = 30;

var

  a:array[1..n] of byte;

  i, count:integer;

begin

  randomize;

  for i := 1 to n do

  begin

    a[i] := random(51) + 150;

    writeln('Рост претендета № ', i:2, ' - ', a[i]);

  end;

  write('Номера подходящих кандидатур: ');

  for i := 1 to n do

    if a[i] >= 180 then

    begin

      inc(count);

      write(i, ' ');

    end;

  writeln;

  writeln('Общее количество подходящих претендентов: ', count);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота