vovkahooligan
24.06.2022 09:14

Напишите программу для вывода на экран последовательности символов: abbccc… напишите программу, которая выводит «да», если буква «а» встречается в тексте чаще, чем буква «о», и «нет» в обратном случае. поменяйте местами k первых и k последних символов строки. удвойте вхождение буквы в текст. например, если пользователь ввёл текст «мама мыла раму» и выбрал для удвоения букву «м», то после работы программы должно быть выведено на экран сообщение «ммамма ммыла рамму» проверьте написанный текст на правильность написания сочетаний «жи», «ши». если слова написаны с ошибкой – исправьте их. удалите в каждом слове предложения первую и последнюю букву.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ammaa09
13.06.2020 02:26

1)Program Z1;
Var st:string;
i,j,k:integer;
Begin
k:=ord('A');
For i:=1 to 26 do begin
For j:=1 to i do begin
write(chr(k));
end;
k:=k+1;
end;
end.


2)Program Z2;
Var st:string;
i,c,c1:integer;
Begin
Writeln('Введите строку');
Readln(st);
For i:=1 to length(st) do begin
if st[i]='а' then inc(c);
if st[i]='о' then inc(c1);
end;
if c>c1 then writeln('Да')
else writeln('Нет');
end.


3)Program Z3;
Var st,st1,st2,st3:string;
k,n:integer;
Begin
Writeln('Введите строку');
Readln(st);
Writeln('Введите k');
Readln(k);
n:=length(st);
st1:=copy(st,1,k);
st2:=copy(st,n-k+1,k);
st3:=copy(st,k+1,n-2*k);
st:=st2+st3+st1;
Writeln(st);
end.


4)Program Z4;
Var st,st1,st2:string;
n,i:integer;
Begin
Writeln('Введите строку');
Readln(st);
Writeln('Введите букву для удвоения');
Readln(st1);
n:=length(st);
For i:=1 to n do begin;
if st[i]=st1 then st2:=st2+st[i]+st[i]
else st2:=st2+st[i];
end;
Writeln(st2);
end.


5)Program Z5;
Var st,st1:string;
n,i:integer;
Begin
Writeln('Введите строку');
Readln(st);
n:=length(st);
For i:=1 to n do begin
if (st[i]='ж') or (st[i]='ш') then st1:=st1+st[i]+'и'
else st1:=st1+st[i];
end;
writeln(st1);
end.


6)Program Z6;
Var st,st1:string;
n,i:integer;
Begin
Writeln('Ââåäèòå ñòðîêó');
Readln(st);
n:=length(st);
st:=' '+st+' ';
For i:=1 to n do
if st[i]=' ' then begin delete(st,i+1,1); delete(st,i-1,1);
end;
writeln(st);
end.

(Все программы проверени и откомпелированы на Pascal. NET, Если есть вопросы, пишите.)

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота