Anna050503
05.10.2021 17:05

Написать программу (Pascal abc) нахождения порядкового номера члена арифметической прогрессии (больше нуля) значение которого будет положительным при заданном первым члене арифметической прогрессии (строго меньше нуля)

*Арифметическая разность больше нуля

*Первый член меньше нуля

*При вводе данных обеспечить проверку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hzhwhsbsh
18.01.2023 18:42
Var
   A,k,S,M:integer;
   P:real;
Begin
Write('Введите натуральное число: ');ReadLn(A);
k:=0;
S:=0;
P:=1;
While A>0 do
   Begin
   M:=A mod 10;
   if M = 3 then k:=k+1
   else
      Begin
      if M > 5 then S:=S+M;
      if M > 7 then P:=P*M;
      End;
   A:=A div 10;
   End;
WriteLn('k = ',k);
WriteLn('S = ',S);
WriteLn('P = ',P);
End.

Var
   A:integer;
   Max,Min,M:byte;
Begin
Write('Введите натуральное число: ');ReadLn(A);
Max:=0;
Min:=10;
While A>0 do
   Begin
   M:=A mod 10;
   if M<Min then Min:=M;
   if M>Max then Max:=M;
   A:=A div 10;
   End;
WriteLn('Min = ',Min);
WriteLn('Max = ',Max);
End.
0,0(0 оценок)
Ответ:
optymus
18.08.2020 15:19
#include <iostream>
#include <map>
#include <string>
using namespace std;

int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота