AnnaM448
28.06.2022 15:11

Написать программу паскаль УТЮГ

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
avruchka7
09.12.2020 06:40

ответ

4,0/5

2

SilverWind

   середнячок

   8 ответов

   2.6 тыс. пользователей, получивших

1. вывести на экран 6 раз своё имя

program imya;

const n=6;

var i:integer;

begin

for i:=1 to n do

writeln('ваше имя');

end.

Пояснения: делала с цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).

2. program sum;

var sum:integer;

m:array[1..4] of integer;

i:integer;

begin

m[1]:=6

for i:=2 to 4 do begin

m[i]:=m[i-1]+1;

end;

sum:=m[1];

for i:=2 to 4 do begin

sum:=sum+m[i];

end;

writeln(sum);

end.

Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))

3. program n!;

var n:real;

c:integer;

m:array[1..n] of integer;

begin

readln(n)

m[1]:=1;

for i:=2 to n do begin

m[i]:=m[i-1]+1;

end;

c:=m[1]

for i:=1 to n do begin

c:=c*m[i];

end;

writeln('n!',c);

end.

Если что не понятно, пишите, объясню

Объяснение:

сосиска

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота