ангелочек1631
24.03.2020 20:24

От это очень Напишите программу вычисления чисел от 35 до 79 с вычислением цикла циклических алгоритмов,циклов с параметром.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NastyuZnanija
25.11.2021 18:06

Шаг 1.

В алфавите, согласно условию задачи, ровно 15 символов.

Шаг 2.

Давайте посмотрим, сколько нужно минимум выделить бит на 1 символ из алфавита, состоящего из 15 символов.

Если бы мы выделили 1 бит информации, то он бы смог закодировать 1 символ алфавита, состоящего не более чем из 2 символов. А у нас их 15 Значит, 1 бита мало.

Если выделить 2 бита, то закодировать можно символ в алфавите максимум из 4 символов. Мало.

Если выделить 3 бита, то закодировать можно символ в алфавите максимум из 8 символов. Мало.

Если выделить 4 бита, то закодировать можно символ в алфавите максимум из 16 символов. Достаточно.

Значит, для кодирования 1 символа данного алфавита достаточно 4 бит.

Шаг 3.

1 пароль состоит из 15-ти символов.

1 символ "весит" 4 бита.

Значит, 15 символов будут "весить" 15х4=60 бит.

Шаг 4.

1 пароль по условию кодируется минимально возможным целым количеством байт.

Сколько байт нужно для хранения пароля из 60 бит?

7 байт мало, так как 7 байт = 7х8 = 56 бит.

8 байт — в самый раз: 8 байт = 8х8=64 бита.

Следовательно, для хранения одного пароля нужно 8 байт.

Шаг 5

Один пароль "весит" 8 байт.

У нас — 20 пользователей (и 20 паролей соответственно).

Следовательно, они "весят" 8х20 = 160 байт.

Шаг 6

Выделено было 400 байт под пароли.

Чисто на хранение, согласно п.5, было использовать 160 байт.

Значит, осталось на дополнительную информацию300-160=140 байт.

Шаг 7

140 дополнительных байт имеется подо все пароли.

Всего паролей — 20.

Значит, под каждый дополнительно выделяется 140/20=7 байт.

ответ: по 7 байт дополнительно выделено для хранения одного пароля.

Объяснение:

0,0(0 оценок)
Ответ:
alinkaaa3
22.06.2022 05:52

/*Простейшая реализация. Подразумевается, что вводятся корректные данные, n вмещается в int, а a и результат - в double. Визуализация зависимости числа операций умножения от степени n для чисел от 0 до 5000 прилагается */

#include <iostream>

double s_pow(double a, int power)

{

       if (power == 0)

       {

               return 1;

       }

       if (power % 2 == 0)

       {

               return s_pow(a * a, power / 2);

       }

       return a * s_pow(a, power - 1);

}

int main()

{

       double a;

       int n;

       std::cin >> a >> n;

       std::cout << s_pow(a, n);

       return 0;

}


Быстрое возведение в степень Возводить в степень можно гораздо быстрее, чем за n умножений! Для этог
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота