sedelnickovm
01.03.2023 19:41

Написать программу, которая выводит сумму чисел, которые делятся на 3 и на 5, в диапазоне от 1536 до 10500. написать в pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anton3228
09.06.2021 09:40

ответ: до сих пор вы использовали линейные алгоритмы, т.е. алгоритмы, в которых все этапы решения выполняются строго последовательно. сегодня вы познакомитесь с разветвляющимися алгоритмами.

определение. разветвляющимся называется такой алгоритм, в котором выбирается один из нескольких возможных вариантов вычислительного процесса. каждый подобный путь называется ветвью алгоритма.

признаком разветвляющегося алгоритма является наличие операций проверки условия. различают два вида условий - простые и составные.

простым условием (отношением) называется выражение, составленное из двух арифметических выражений или двух текстовых величин (иначе их еще называют ), связанных одним из знаков:

< - меньше,

> - больше,

< = - меньше, или равно

> = - больше, или равно

< > - не равно

= - равно

например, простыми отношениями являются следующие:

x-y> 10; k< =sqr(c)+abs(a+b); 9< > 11; ‘мама’< > ‘папа’.

в примерах первые два отношения включают в себя переменные, поэтому об истинности этих отношений можно судить только при подстановке конкретных значений:

если х=25, у=3, то отношение x-y> 10 будет верным, т.к. 25-3> 10

если х=5, у=30, то отношение x-y> 10 будет неверным, т.к. 5-30< 10

проверьте истинность второго отношения при подстановке следующих значений:

k=5, a=1, b=-3, c=-8

k=65, a=10, b=-3, c=2

определение. выражение, о котором после подстановки в него значений переменных можно сказать, истинно (верно) оно или ложно (неверно), называется булевым (логическим) выражением.

примечание. название “булевы” произошло от имени джорджа буля, разработавшего в xix веке булеву логику и логики.

определение. переменная, которая может принимать одно из двух значений: true (правда) или false (ложь), называется булевой (логической) переменной. например,

к: =true;

flag: =false;

second: =a+sqr(x)> t

рассмотрим пример.

. вычислить значение модуля и квадратного корня из выражения (х-у).

для решения этой нужны уже знакомые нам стандартные функции нахождения квадратного корня - sqr и модуля - abs. поэтому вы уже можете записать следующие операторы присваивания:

koren: =sqrt(x-y);

modul: =abs(x-y)

в этом случае программа будет иметь вид:

program znachenia;

uses

crt;

var

x, y : integer;

koren, modul : real;

begin

clrscr;

write ('введите значения переменных х и у через пробел ');

readln (x, y);

koren: =sqrt(x-y);

modul: =abs(x-y);

write ('значение квадратного корня из выражения (х-у) равно ', koren);

write ('значение модуля выражения (х-у) равно ', modul);

readln;

end.

казалось бы, решена. но мы не учли области допустимых значений для нахождения квадратного корня и модуля. из курса вы должны знать, что можно найти модуль любого числа, а вот значение подкоренного выражения должно быть неотрицательно (больше или равно нулю).

поэтому наша программа имеет свою допустимую область исходных данных. найдем эту область. для этого запишем неравенство х-у> =0, то есть х> =у. значит, если пользователем нашей программы будут введены такие числа, что при подстановке значение этого неравенства будет равно true, то квадратный корень из выражения (х-у) извлечь можно. а если значение неравенства будет равно false, то выполнение программы закончится аварийно.

. наберите текст программы. протестируйте программу со следующими значениями переменных и сделайте вывод.

х=23, у=5;

х=-5, у=15;

х=8, у=8.

каждая программа, насколько это возможно, должна осуществлять контроль за допустимостью величин, участвующих в вычислениях. здесь мы сталкиваемся с разветвлением нашего алгоритма в зависимости от условия. для реализации таких условных переходов в языке паскаль используют операторы if и case, а также оператор безусловного перехода goto.

рассмотрим оператор if.

для нашей нужно выполнить следующий алгоритм:

если х> =у,

то вычислить значение квадратного корня,

иначе выдать на экран сообщение об ошибочном введении данных.

объяснение:

0,0(0 оценок)
Ответ:
89518099647
15.08.2021 05:05
1.Программа к саморазмножению (Вирус)
2.Световая метка на экране, обозначающая место активного воздействия (Курсор)
3. Процесс сжатия информации с целью уменьшения её объёма (Архивация)
4. Устройство вывода звуковой информации (Колонки)
5. Специализированный сетевой компьютер пересылающий пакеты данных между различными сегментами сети (Роутер)
6. Устройство ввода (Клавиатура)
7. Устройство для чтения и записи дисков (Дисковод)
8. Описание операции (Команда)
9. Знак, вместе с его смыслом (Символ)
10. Определнное количество информации, хранящаяся во внешней памяти и имеющее имя (Файл)
11. Микросхема, которая обрабатывает информацию и управляет всеми устройствами ПК (Процессор)
12. Гибкий магнитный диск (Дискета)
13. Сверхоперативная память (Кэш)
14. Устройство вывода информации (Монитор)
15. Группа файлов и папок, объединенных по какому-либо принципу (Каталог)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота