ba4Ka
13.01.2022 09:24

9 класс. Написать программу, блок-схему и таблицу изменения значений, используя цикл с постусловием: выброс вредных веществ в атмосферу составил Х тонн. Каждые сутки

количество вредных веществ снижается в К раз. Через сколько суток количество ВВ

составит норму У? X=567.Y=4 K=2,6

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
047oksana
19.08.2020 12:12
Если число кратно 7 и 9 одновременно, то оно кратно и их произведению, т.е. 63.

PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите границы интервала');
  if a>b then Swap(a,b);
  var m:=a mod 63;
  if m>0 then a:=a+63-m
  else if m<0 then a:=a-m;
  var s:=Range(a,b,63);
  Writeln('На интервале для чисел, кратных 7 и 9 одновременно:');
  Writeln('Количество ',s.Count,', сумма ',s.Sum,', произведение ',
      s.Aggregate(BigInteger(1),(p,q)->p*q))
end.

Пример
Введите границы интервала 613 2100
На интервале для чисел, кратных 7 и 9 одновременно:
Количество 24, сумма 32508, произведение 365675480699261550432828460140720056759879856012024400651039614959616000000
0,0(0 оценок)
Ответ:
CrySony1
19.02.2022 08:39

program HelloWorld;

var n:array [1..6] of string;

var i,k,j: smallint;

begin

   

    n[1] := '1+';

    n[2] := '2+';

    n[3] := '3+';

    n[4] := '4+';

    n[5] := '5+';

    n[6] := '6';

   

    k :=  0;

    for i:=1 to 6 do

      if pos('+',n[i]) > 0 then k := k + 1;

 

    if k>4 then

        for i:=1 to 6 do

        begin

           j := pos('+',n[i]);

           if j > 0 then

           begin

            delete(n[i],j,1);

            insert('=',n[i],j);

           end;

        end;

 

    for i:=1 to 6 do

      writeln(n[i]);

 

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота