Zer2806
14.04.2021 06:21

Написать программу для вычисления заданного выражения. Значение x вводится пользователем с клавиатуры. Значение e приблизительно равно 2,71828 принять его в качестве константы


Написать программу для вычисления заданного выражения. Значение x вводится пользователем с клавиатур
Написать программу для вычисления заданного выражения. Значение x вводится пользователем с клавиатур

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Inpeakfhdh
06.02.2021 12:43

10000x4000x500x30x4

Цифры числа расположены в определенных позициях, которые соответствуют (справа налево) единицам, десяткам, сотням, тысячам и так далее. Определите название позиции и ее значение для каждой цифры (справа налево).

Пример: так как в данном числе четыре цифры, то вам нужно определить названия четырех позиций (справа налево).

7 соответствует единицам (значение = 1).

2 соответствует десяткам (значение = 10).

8 соответствует сотням (значение = 100).

5 соответствует тысячам (значение = 1000).

0,0(0 оценок)
Ответ:
Marg06
07.11.2021 10:49

#include <iostream> // подключаем библиотеку потокового ввода/вывода (cout/cin/...);

#include <ctime> // подключем библиотеку для возможности изменения стандартного генератора чисел (srand(...));

int main()

{

using namespace std; // используем пространство имен std;

setlocale(LC_ALL, "ru"); // возможность использования русского текста в консоли;

srand(time(NULL)); // генератор случайных числе;

const int N = 10;  // константный размер массива;

int A[N][N]; // обьявление двумерного массива;

cout << "Исходный двумерный массив: " << endl;

for (int i = 0; i < N; i++) // проходим по двумерному массиву используя 2 цикла;

{

 for (int j = 0; j < N; j++)

 {

  A[i][j] = rand() % 50; // заполняем двумерный массива случайными числами от 0 до 50;

  cout << A[i][j] << '\t'; // и сразу выводим его на экран;

 }

 cout << endl;

}

// ищем минимальное значение в массиве:  

int min = A[0][0]; // предположим, что первый элемент массива это минимальный элемент;

for (int i = 0; i < N; i++) // проходим по двумерному массиву используя 2 цикла;

{

 for (int j = 0; j < N; j++)

 {

  // если текущий элемент массива меньше min, тогда присваиваем переменной min это значение. Таким образом мы найдем минимальный элемент;

  if (min > A[i][j]) // если в теле условия/цикла ожидается 1 инструкция, то { } можно не ставить;

   min = A[i][j];

 }

}

// обнуляем все элементы массива, кроме элементов, расположеных на главной диагонали:

for (int i = 0; i < N; i++) // проходим по двумерному массиву используя 2 цикла;

{

 for (int j = 0; j < N; j++)

 {

  // если i будет равен j, то получится что мы идем по глвной диагонали: i=1:j=1, i=2:j=2, i=3:j=3 ...

  // поэтому, если i не равен j обнуляем элемент;

  if (i != j)  

   A[i][j] = 0;

 }

}

cout << "\nРезультат: " << endl;

for (int i = 0; i < N; i++)  // проходим по двумерному массиву используя 2 цикла;

{

 for (int j = 0; j < N; j++)

 {

  cout << A[i][j] << '\t'; // выводим то что получилось в консоль;

 }

 cout << endl;

}

cout << "\nМинимальный элемент в двумерном массиве = " << min << endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота