ghbdtnzujdyjfns
24.06.2021 10:25

7. Написать программу, которая из слова «ПРОГРАММИРОВАНИЕ» получает слово «грамм» (маленькими буквами).
8. Составить программу, которая во введенной строке заменяет все точки и
запятые на «!».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
imail91
24.11.2021 15:20

информатика-это наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений

информа́ция — сведения независимо от формы их представления.

свойства информации

1)ценность

максимально возможная польза для достижения цели

2)актуальность

соответствие текущему моменту времени

3)достоверность

истинность представлений об источнике информации

4)доступность (понятность)

способность потребителя к восприятию информации

5)объективность

отображение внешнего мира независимо от наблюдателя

6)полнота

степень подробностей представлений об объекте

процессы информации

1)передача информации

процесс перемещения данных от одного пункта (источника) к другому (приемника)

2)хранение информации

действия с целью защиты найденной информации от потери, повреждения, разрушения

3)обработка информации

совокупность целенаправленных действий с полученной информацией для получения новой информации

этапы эвм

первое поколение

элементная база эвм первого поколения (конец 40-х — середина 50-х) — электронные схемы, построенные с использованием радиоламп. пример эвм первого поколения — бэсм-1(1950г.) — содержала около 7000 радиоламп, выполняла около 8000 арифметических и логических операций в секунду. , решаемые этой машиной: эксперименты по переводу научно-технических текстов с на язык, шахматные . бэсм-1 занимала большой зал, где требовалась вентиляция, стабильные источники питания, смена ламп. примеры других эвм первого поколения: цвм стрела, минск-1, м-20 и др.

  второе поколение

основа элементной базы эвм второго поколения (сер. 50-х — 70-х гг.) — элементы (, диоды). приборы позволили резко увеличить скорость выполнения операций, и быстродействие достигло нескольких миллионов операций в секунду. в эвм второго поколения использовались зу с объемом памяти на сотни тысяч машинных слов. эвм второго поколения: бэсм-2, бэсм-3, бэсм-3м, машины серии урал, мир, наири и др.

третье поколение

третье поколение эвм связывают с использованием интегральных схем (ис) среднего уровня интеграции. на одном кристалле реализуются достаточно сложные логические функции, и из них собираются сложные узлы машин. примеры эвм третьего поколения: ibm — 360, урал-12, урал-13, урал-14. самые большие семейства машин третьего поколения — это ес эвм (единой серии). быстродействие этих машин: сотни тысяч операций в секунду, объем памяти — сотни тысяч машинных слов.

0,0(0 оценок)
Ответ:
лизанезнающая
14.11.2022 13:24

var c, s, n, k : integer;  

   x,d :longint;  

begin  

writeln('введите x');  

readln (x);  

k := 0;                             //количество четных цифр в числе

while x > 0 do                     //пока х не равен нолю

begin

 if (x mod 2) = 0 then k := k + 1; //проверяем четна ли последняя цифра числа

                                   //+1 к кол-ву четных цифр

 x := x div 10;                    //сокращаем на один знак и повторяем операцию

end;

if k >= 2 then  

writeln('Да')                       //если кол-во четных цифр больше 2

                                    //выводим 2, иначе не выводим ничего

end.

/* Вот написал сам, но то что пытался сделать ты не понял */

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота