veikson
29.05.2020 01:39

Вариант 3. 7. Написать программу, которая из слова «программирование» получает
слово «РОВ» (большими буквами).
8. Написать программу, которая определяет, какой процент слов во введенной
строке заканчивается на букву «Я»»
Ребята

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
главный13
21.10.2021 09:05

Var  a, d, n, i, otv: integer;

begin

  read(a,d,n);                                - ввод всех значений

  otv:=a;                                        - в переменную где будет храниться

  for i:=1 to n do                              ответ записываем начальный взнос

  begin

     a:=a+d;                                     - увеличиваем в цикле взнос

     otv:= otv + (a);                         - добовляем взнос к нашему ответу

  end;

  writeln(otv);                                 - выводим ответ

end.

0,0(0 оценок)
Ответ:
Sewrc
18.04.2022 14:52

program spk;

var i,s,k:integer;

p:real;

a:array [1..10] of integer;

begin

for i:=1 to 10 do a[i]:=random(81)-30;

for i:=1 to 10 do write(a[i],'  ');

for i:=1 to 10 do if i mod 2 = 0 then s:=s+a[i];

p:=1;

for i:=1 to 10 do if a[i] < 0 then p:=p*a[i];

for i:=1 to 10 do if a[i] mod 2 <> 0 then k:=k+1;

write('s = ',s,'   p = ',p,'   k = ',k);

end.

Объяснение:

program spk;

var a:array [1..10] of integer;

i,s,k:integer;

p:real;

begin

p:=1;

write('Массив: ');

for i:=1 to 10 do

begin

a[i]:=random(81)-30;

write(a[i],'  ');

if i mod 2 = 0 then s:=s+a[i];

if a[i] < 0 then p:=p*a[i];

if a[i] mod 2 <> 0 then k:=k+1

end;

writeln;

writeln('Сумма элементов массива, с четными номерами, равна ',s);

writeln('Произведение отрицательных элементов равно ',p);

writeln('Количество нечётных элементов равно ',k)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота