яЭльф
29.07.2022 18:17

Напишите программу(на Паскале) вычисления суммы всех положительных элементов массива, которые вводятся с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
динозаврррррр
07.01.2021 05:56

var i, sum, num : integer;

var D: array [0..10] of integer;

begin

 sum := 0;

 

 for i:= 0 to 10 do begin

   readln(num);

   D[i] := num;

 end;

 

 for i := 0 to 10 do begin

   if D[i] >= 0 then

     sum := sum + D[i];

 end;

 

 writeln('Результат = ' + sum);  

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота