806amanova
06.03.2021 02:01

составить программу в паскаль abc - математический маятник, качающийся из стороны в сторону и постепенно затухает.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Milana2K18
04.01.2020 20:56
. var a, b: real;
begin
  write('Введите стороны прямоугольника: ');
  read(a, b);
  writeln('Периметр = ', 2 * a + 2 * b);  
end.

2. var p, b: real;
begin
  write('Введите два числа: ');
  read(p, b);
  writeln('Произведение = ', p * b);
  writeln('Разность = ', p - b);
end.

3. var b: real;
begin
  write('Введите длину ребра: ');
  read(b);
  writeln('Объем = ', b * b * b);
end.

4. var r: real;
begin
  write('Введите радиус: ');
  read(r);
  writeln('Площадь = ', 3.14 * r * r);
end.

5. var a, b, c: real;
begin
  write('Введите три стороны: ');
  read(a, b, c);
  writeln('Периметр = ', a + b + c);
end. 
0,0(0 оценок)
Ответ:
Alexader2352
04.01.2020 20:56

1)
program s_parallelogramm;
var
a,h,s: real;
begin
write('Основание = '); readln(a);
write('Высота = '); read(h);
if ((a=0) or (a<0)) or ((h=0) or (h<0)) then writeln('Ошибка! Значения основания и высоты должно быть натуральными числами')
else
begin
s:=a*h;
writeln('Площадь (S) параллелограмма = ', s);
end;
end.

2)
program sp_kvadrata;
var
a,p,s: real;
begin
write('Сторона квадрата = '); readln(a);
p:=4*a;
s:=sqr(a);
writeln('Периметр (P) квадарата = ', p);
writeln('Площадь (S) квадарата = ', s);
end.

3)
program e_kinet;
var
m,v,e: real;
begin
write('Масса тела (m, кг) = '); readln(m);
write('Скорость тела (v, км/ч) = '); readln(v);
e:=m*sqr(v)/2;
writeln('Кинетическая энергия (Ек, Дж) = ', e);
end.

1)
program vivod_chisel;
var
i, a: integer;
begin
a:=11;
for i:=1 to 45 do
begin
write(a:3);
a:=a+2;
end;
end.

2)
program sym_trex_chisel_krat5;
var
mas: array[1..900] of integer;
i,a,sym: integer;
begin
a:=100;
sym:=0;
for i:=1 to 900 do
begin
mas[i]:=a;
if mas[i] mod 5 = 0 then sym:=sym+mas[i];
a:=a+1;
end;
writeln('Сумма трехзначных чисел, кратных 5 = ', sym);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота