bogdanzdebskiy
28.02.2021 11:00

Напишите программу, которая считает количество чётных цифр введённого числа. ---Входные данные---
Входная строка содержит одно натуральной число N .

---Выходные данные---
Программа должна вывести количество чётных цифр введённого числа.
ПРИМЕР
Ввод
123456
Вывод
3
Ввод
13579
Вывод
0
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(фунции или процедуры)!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ekaterinkavas20
07.01.2021 03:59

#include <iostream>  

using namespace std;

int main()

{

   long long a, sum = 0;

   cin >> a;

   while(a)

   {

       if((a%10) % 2)

           sum++;

       a/=10;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота