ijezz
06.07.2021 03:03

Решите 2 в паскале! ! 1) вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 в остатке 4, и их колличество. конец программы: sumchis : =0; for i: 1 to 100 if i mod 6 = 4 then begin writeln (i); sumchis : =sumchis +1; end. написать надо начало программы! 2) написать программу, которая выводит натуральные числа до 10 000 включительно, которые при делении на 17 остаток 11 или b

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ahmedovadidi090
30.09.2020 23:51

1)

var sumchis, i:integer;

begin

for i:=1 to 100 do begin

if i mod 6 =4 then

begin

writeln(i);

sumchis:=sumchis+1;

end;

end;

writeln('Колличество чисел', sumchis);

end.

 

2)

var sumchis, i:integer;

begin

for i:=1 to 10000 do begin

if i mod 17 =11 then

begin

writeln(i);

sumchis:=sumchis+1;

end;

end;

writeln('Колличество чисел', sumchis);

end.

 

Как сделать чтобы остаток равнялся B - не знаю, так как программа начинает считывать её как за переменную, если только B определить как переменную и в неё внести значение какое-то.

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота