Lybasha7
27.10.2021 14:30

Составить программу в паскале! 9 класс! ! написать программу, по длинам сторон распознающую среди всех треугольников abc прямоугольные. если таких нет, то вычислить величину угла с.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lissa000
12.06.2020 21:24

const Radian = 57.295779513;  //Сколько градусов в одном радиане

var 

  a, b, c: real;  //Стороны, лежащие против углов A, B и C соответственно

 

begin

  writeln('Введите 3 стороны треугольника в следующем порядке: a, b, c');

  readln(a, b, c);

  if (sqr(a) = sqr(b) + sqr(c)) or (sqr(b) = sqr(a) + sqr(c)) or (sqr(c) = sqr(a) + sqr(b)) then writeln('Треугольник ABC - прямоугольный')  {Если хотя бы для одной из сторон выполняется теорема Пифагора, то данный треугольник прямоугольный}

  else writeln('Угол C равен: ', arccos((sqr(a) + sqr(b) - sqr(c)) / (2 * a * b)) * Radian, ' градусов');  {Выражаем из теоремы косинусов косинус угла C, берем arccos от него и умножаем получившееся значение на количество градусов в радиане, чтобы получить ответ в градусах}

end.

Пользоваться компилятором Pascal ABC.Net, потому что это единственный компилятор из всех известных мне, который поддерживает функцию arccos.

Если будут вопросы, спрашивай.

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота