ДинислаМММ
22.03.2020 17:28

Методы вычисление Матлаб. Составить программу, которая в каждой строке матрицы Z(m, n), m<10,
nS12 находит элемент, для которого модуль разности элемента и среднего геометрического модулей всех элементов строки максимален. Предполагается, что матрица нулевых элементов не содержит. Вывести матрицу в виде матрицы, располагая рядом с каждой строкой найденный элемент и модуль искомой разности.

КАК ЭТО РЕШАТЬ, УЖЕ НЕДЕЛЮ ГОЛОВУ ЛОМАЮ.​ Нужно решить через Матлаб. Объясните как это сделать, кто разбирается очень вас.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
186Kbkz
05.08.2020 22:33

C#:

int a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введите номер одного из зимних месяцев:\n12, 1, 2");              

               a = Convert.ToInt32(Console.ReadLine());

               switch (a)  

               {  

               case 12:                                  

                  Console.WriteLine("Декабрь\n");              

                  break;

               case 1:

                  Console.WriteLine("Январь\n");

                  break;

               case 2:

                  Console.WriteLine("февраль\n");

                  break;

                default:                        

                  Console.WriteLine("Не зимний месяц\n");

                  break;

               }

//Ниже идёт зацикливание программы, для удобства. Если Вам этого не требуется, то вместо нижеперечисленного впишите "Console.ReadKey();"

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


Дан номер зимних месяцев (12- декабрь, 1- январь, 2 – февраль). Напишите код программы, которая выво
0,0(0 оценок)
Ответ:
petrovvalera05
15.12.2022 09:59
Все довольно просто, мог бы и сам прогнать через ide!) 
1) const a: array [1..6] of integer=(1, 7, 3,6,0,10);  тут ты инициализируешь массив которые включает 6 элементов такие как: (1, 7, 3,6,0,10)
2) после ты по циклу начинаешь складывать все элементы массива, которые описаны выше - for i:=1 to 6 do s:=s+a[i]; т.е. 1+7+3+6+0+10
3) далее ты делишь сумму на 6 и присваиваешь результат переменной sr - sr:=s/6;
4) после этого пытаешься вывести значение переменной sr - writeln(‘sr=’, sr); 

ответ будет 4.5, но твоя программа не выполниться, т.к. 4.5 это дробное число, а у тебя на переменную sr стоит тип integer, для того, чтобы программа отработала и вывело ответ, сделай тип переменной sr: real и тогда у тебя все получиться =)

Если есть вопросы, то пиши
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота