dyba2003
23.06.2020 19:39

составить программу в паскале, и пишите комментарий в коде, что бы было понятно какое действие для чего


составить программу в паскале, и пишите комментарий в коде, что бы было понятно какое действие для ч

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
FACCE
03.03.2022 08:56

program one;


type TIntMassiv = array of real;


var a,b,c,x,y: TIntMassiv; n,i:integer;


begin


writeln('Введите длину массивов(n)');


readln(n);


setLength(a,n); // Создаем динамические массивы длины n


setLength(b,n);


setLength(c,n);


setLength(x,n);


setLength(y,n);


for i := 0  to n-1 do  

 begin


  writeln('Введите ',i+1, ' массива a');


  readln(a[i]);  

  writeln('Введите ',i+1, ' массива b');


  readln(b[i]);  

  writeln('Введите ',i+1, ' массива c');


  readln(c[i]);


 end;


for i := 0 to n-1 do


 begin


  x[i] :=  MIN(a[i],b[i]) / 2;


  y[i] :=  MIN(a[i],c[i]) / 2;


 end;


for i := 0 to n-1 do


 begin


  writeln('x[',i,']=',x[i]);


  writeln('y[',i,']=',y[i]);


 end;


a := nil; //Освобождаем память


c := nil;


b := nil;


x := nil;


y := nil;


end.

0,0(0 оценок)
Ответ:
Артёмка12097
26.01.2021 08:54

ЗАДАНИЕ 1:

#include <iostream>

using namespace std;

void main()

{

   int number = 0;

   cout << "Введите число ->";

   cin >> number;

   if (number % 2 == 0)

   {

       number *= 3;

   }

   else

   {

       number /= 2;

   }

   cout << number << endl;

}


ЗАДАНИЕ 2:

#include <iostream>

#include <cctype>

using namespace std;

void main()

{

   char symbol = 0;

   cout << "Введите символ ->";

   cin >> symbol;

   if (isalpha(symbol))

   {

       cout << "Вы ввели букву" << endl;

   }

   else if (isdigit(symbol))

   {

       cout << "Вы ввели цифру" << endl;

   }

   else if (ispunct(symbol))

   {

       cout << "Вы ввели знак препинания" << endl;

   }

   else

   {

       cout << "Вы ввели не букву, не цифру и не знак препинания" << endl;

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота