Makalllla1122
02.01.2020 01:55

Составить программу и блок схему по примеру Y=48(28x^2-15)... (10 класс) Нужно составить программу по заданному примеру при x=11,7
Фото внизу:
Нужно


Составить программу и блок схему по примеру Y=48(28x^2-15)... (10 класс) Нужно составить программу п

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
miragrrr
16.02.2021 11:40

Алгоритм печатает сначала L, потом M. По программе понятно, что L Это количество раз, когда число не кратно 10 (каждый раз число делится на 10), а M - общее количество цифр. Понятно, что раз число должно быть наименьшее, а всего 8 цифр, значит может быть как минимум 4 нуля. Больше нулей быть не может, т.к. если в числе есть значимый ноль, то при делении он будет давать кратность десяти. 4 цифры уже есть, осталось подобрать 4 цифры, которые в числе при делении его на 10 не будут давать остаток 0. Это любые цифры от 1 до 9, но так как число минимальное, значит это цифры "1". Получается, 11110000. Переставляем цифры так, чтобы число было минимальное и получается 10000111.

ответ: 10000111

0,0(0 оценок)
Ответ:
киреева2
20.06.2022 21:58

Это первый вариант (но им лучше не пользуйся , ибо препод может придраться )

var  

a,b:integer;        

c:boolean;


begin


readln (a);


b:=0;


   begin  

   if (a div 10>0) then b:=b+1;


   if (a mod 5=0) then b:=b+1;


   end;


c:=b=2;


writeln (c);


end.

Вот второй вариант ( который не так сильна закручен )

var  

a:integer;


c:boolean;


begin


readln (a);


c:= (a div 10>0) and (a mod 5=0);


writeln (c);


end.

Объясняю второй вар:

var - мы вводим переменные

a:integer; - это значит что число а- целое

c: boolean; - вводим переменную которая дает истинность высказывания

begin - начало алгоритма

readln (a);- компуктер запросит  чтобы вы ввели переменную "a"

c:= (a div 10>0) and (a mod 5=0) - c будет истинен при том случае если a div 10>0 (при делении а на 10 целая часть будет больше 0) и a mod 5=0 (при делении a на 5 остаток будет 0)

writeln (с); - выводим с (True or False)

end. -конец алгоритма

Надеюсь, что понятно объяснил.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота