frost79naumenkow6nt4
23.05.2020 13:52

решить задачи на PYTHON. Какие сможете. Буду оооченьь признательнааа
1. Вводится последовательность целых чисел. Известно, что последний элемент последовательности равен 5. Найдите количество положительных чисел и минимальное из них. Разработайте программу для чисел в диапазоне [- 10000..10000]
2. Вводится последовательность целых чисел. Известно, что последний элемент последовательности равен 1. Определите, каких среди них больше: положительных или отрицательных.
3. Известны начальный вклад клиента в банк и процент годового дохода. Определите срок (в годах), через который вклад превысит 1 млн рублей и величину этого вклада.
5. Дано число, определите минимальное основание системы счисления, в которой оно может быть записано. (Максимальная система счисления 10)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
кудряшёв
03.09.2022 10:16

Объяснение:

базовое программное обеспечение (base software) – минимальный набор программных средств, обеспечивающих работу компьютера.

в него входят операционная система (предназначена для управления выполнением пользовательских программ, управления вычислительными ресурсами), операционные оболочки (сециальные программы, которые предназначены для упрощения работы пользователя с командами операционной системы, имеют текстовый и графический варианты интерфейса), сетевая операционная система (комплекс программа, который обеспечивает обработку, передачу и хранение данных в сети).

0,0(0 оценок)
Ответ:
vika12330
05.02.2022 19:14

Объяснение:

PascalABC.NET. Версия 3.5.1, сборка 2261 (4.11.2019)Задание 1

program abc;

const n=2; // Задание начальных параметров массива через константы

const m=2;

var C:array[1..n,1..m] of integer;

A:array[1..n,1..m] of integer;

B:array[1..n,1..m] of integer;

i,j:integer;

begin

 for i:=1 to n do

   for j:=1 to m do

    begin

     readln(A[i,j]); // Ввод данных и вычисление по формуле

     readln(B[i,j]);

     C[i,j]:=A[i,j]+B[i,j];

    end;

  writeln('C[n,m] = ');

  for i:=1 to n do

   begin

    for j:=1 to m do

     write(C[i,j],' '); // Вывод массива

    writeln;

   end;

end.

Задание 2

program abc;

const n=3; // Задание начальных параметров массива через константы

const m=3;

var A:array[1..n,1..m] of integer;

i,j:integer;

begin

 for i:=1 to n do

   for j:=1 to m do  // Ввод данных массива

     readln(A[i,j]);  

     

 writeln('Оригинальный массив A(n,m):');

 

 for i:=1 to n do  // Вывод оригинального массива

   begin

    for j:=1 to m do

      write(A[i,j],' ');

    writeln;

   end;

  for i:=1 to n do // Замена 2-ого столбца 2-ой строкой

   A[i,2]:=A[2,i];

   

   writeln('Изменённый массив A(n,m):');

     

   for i:=1 to n do // Вывод изменённого массива

   begin

    for j:=1 to m do

      write(A[i,j],' ');

    writeln;

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота