olenkayatsev
23.12.2021 11:46

B C++: Если среднее арифметическое каждого столбца двумерного массива A меньше заданной величины T, заменить значение каждого элемента
массива A квадратом этого значения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Leprekon11
24.01.2021 08:20

1.

Program u666;

Var

x, y, z, t, n, e, z1, z2, z3: real;

Begin

 readln (e, x, y);

 if sqrt (3*y)+x = 14

 then  

 begin

   z1:= Exp(3*x*y);

   z2:= x+3*y;

   z3:= 0.5*x;

   writeln (z1);

   writeln (z2);

   writeln (z3)

 end

 else

   z:= 0;

   writeln (z);

end.

2. Program Regret;

var x: integer;

begin

 read (x);

 if (x=1) or (x=3) or (x=5) or (x=7) or (x=8) or (x=10) or (x=12)

 then write ('31');

 if (x=4) or (x=6) or (x=9) or (x=11)

 then write ('30');

 if (x=2)

 then write ('28')

end.

Объяснение:

Интернет урок)


с информатикой. Задание 1. Картинка. Составить блок-схему алгоритма и программу на Паскале для вычис
с информатикой. Задание 1. Картинка. Составить блок-схему алгоритма и программу на Паскале для вычис
0,0(0 оценок)
Ответ:
Lizaforever11
02.05.2021 12:32
Продемонстрируйте работу метода сортировки вставками по возрастанию. Для этого выведите состояние данного массива после каждой вставки на отдельных строках. Если массив упорядочен изначально, то следует ничего не выводить.

Формат входных данных

На первой строке дано целое число n (1≤n≤100) — количество элементов в массиве. На второй строке задан сам массив: последовательность натуральных чисел, не превышающих 10^9.
Формат выходных данных

В выходной файл выведите строки (по количеству вставок) по n чисел каждая.

Задачу то я решил, вот только тестирующая система говорит, что слишком много написано
Correct
1 2 2 1 2 1
1 1 2 2 2 1
1 1 1 2 2 2

Output
1 2 2 1 2 1
1 2 1 2 2 1
1 1 2 2 2 1
1 1 2 2 1 2
1 1 2 1 2 2
1 1 1 2 2 2
C++Выделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include
#include
using namespace std;
int main(){
int n;
cin >> n;
vector a;
for (int i = 0; i < n; i++){
int b;
cin >> b;
a.push_back(b);
}
for (int i = 1; i < n; i++){
for (int j = i; j > 0; j--){
if (a[j - 1] > a[j]){
swap(a[j], a[j - 1]);
for (auto now : a){
cout << now << " ";
}
cout << "\n";
}
else{
break;
}
}
}
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота