26090204A
12.04.2020 17:50

НУЖНА Дан целочисленный массив из 30 элементов. Элементы массива могут принимать натуральные значения от 1 до 10000 включительно. Составить программу
а) которая находит произведение элементов массива, меньших 100 и при этом имеющих
нечетные значения
б) которая находит минимальный элемент и заменяет каждый элемент массива, меньший 100 и
имеющий нечетное значение на минимальный элемент
в) упорядочить массив по возрастанию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hehsggsvsg
24.05.2022 10:49

from random import randint

S1 = [randint(1,100) for i in range(20)]

summa1 = 0

summa2 = 0

for i in S1:

   if i % 2 == 0:

       summa1 += i

   else:

       summa2 += i

print(f"Сумма чётных = {summa1}")

print(f"Сумма нечёт = {summa2}")

print(max(S1)) # Значение наибольшего элемента в массиве

print(min(S1)) # Значение наименьшего элемента в массиве

summa = 0

for i in S1:

   if i < 30:

       summa += i

print(f"Сумма чисел меньше 30-ти = {summa}")

summa = S1[2]

for i in S1:

   summa *= i

print(f"Произведение элементов с индексов 2({S1[2]}) = {summa}")


Задайте одномерный массив, содержащий 20 элементов, взятых случайным образом из интервала [1, 100].В
0,0(0 оценок)
Ответ:
Dosina
24.04.2023 07:16
1. c) Информационное пространство - это все, откуда пользователь может хотя бы что-то прочитать
2.  с). Во-первых, частота измеряется в герцах, а не в каких-то битах или байтах - это мы знаем еще из физики. Во-вторых, дискретизация - это пересчет уровня сигнала в некие фиксированные уровни, т.е. он связан с измерением величины сигнала.
3. б) Есть понятие "иерархическая файловая система", когда файлы одного уровня "вкладываются" в папку вышележащего уровня и это вложение многократно повторяется. Ближе всего к этому понятию ответ б)
4. д) Управление связано с передачей информации управляемому объекту. Но чтобы управлять, надо получать от этого объекта информацию и каким-то образом её обрабатывать, принимая некоторые решения. Хранить эту информацию надо лишь короткое время. Для примера: управление автомобилем. Водитель перед перекрестком смотрит по сторонам и принимает решение об управлении автомобилем. Но, проехав перекресток, он уже не думает о том, как его проезжал (если не брать в расчет присущие человеку эмоции).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота