Kirillchakilev
12.02.2022 09:20

ЗАДАЧА C++ Напишите программу, которая считывает число x, а затем пишет его, поставив перед ним х пробелов
Формат входных данных
Целое не отрицательное число x (Гарантируется, что x не меньше нуля и не больше 9)
Формат выходных данных
Число x, перед которым стоит x пробелов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mailrujl
04.01.2021 00:56

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   for (int i = 0; i < x; i++) cout << " ";

   cout << x;

}

Объяснение:

0,0(0 оценок)
Ответ:
Ваняяш
04.01.2021 00:56

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE,"Russian");

int x;

cin >>x;

if(x>0 && x<9)

{

for(int i= 0; i<x; i++)

{

cout << " ";

}

cout<<x;

}

else cout<<"Число х не соответсвует диапазону";

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота