кусака22
01.08.2022 08:53

Язык Python 3 Наибольшая возрастающая подпоследовательность

У вас есть массив чисел длиною "N". Нужно найти следующую длину наибольшей возрастающей подпоследовательности. Ниже приведены несколько примеров

[1,3,5,4,7] => 3

[2,2,2,2,2] => 1

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти следующую длину наибольшей возрастающей подпоследовательности.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
astatined
07.02.2022 21:57

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

0,0(0 оценок)
Ответ:
kust2
02.06.2023 08:39

#include <iostream>

 

int main(){

   int a = 0;

   int b = 0;

   char operation;

   std::cout << "Enter first number: ";

   std::cin >> a;

   std::cout << "Enter second number: ";

   std::cin >> b;

   std::cout << "Enter operation: ";

   std::cin >> operation;

 

   switch (operation){

   case '-':

       std::cout << "a - b = " << a - b <<'\n';

       break;

   case '+':

       std::cout << "a + b = " << a + b << '\n';

       break;

   case '*':

       std::cout << "a * b = " << a * b << '\n';

       break;

   case '/':

       std::cout << "a / b = " << a / b << '\n';

       break;

   default:

       std::cout << "Error\n";

   }

   return 0;

}

Объяснение: Это на C++

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота