dina08254
13.12.2020 13:51

Составьте программу вычисления длин сторон прямоугольного треугольника площадью S, у которого длина одного катета в два раза больше другого

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mkogavuk
15.11.2021 01:47
Var
  xa,ya,xb,yb,d2a,d2b:real;
begin
  Write('Введите координаты (x,y) точки А: '); Readln(xa,ya);
  Write('Введите координаты (x,y) точки B: '); Readln(xb,yb);
  d2a:=sqr(xa)+sqr(ya); d2b:=sqr(xb)+sqr(yb);
  if d2a<d2b then Writeln('Точка А расположена ближе к началу координат')
  else
    if d2b<d2a then Writeln('Точка B расположена ближе к началу координат')
    else Writeln('Обе точки равноудалены от начала координат')
end.

Тестовое решение:
Введите координаты (x,y) точки А: 5 -3.7
Введите координаты (x,y) точки B: -4.2 3.8
Точка B расположена ближе к началу координат
0,0(0 оценок)
Ответ:
GoodArtur
27.05.2020 13:30
1. \ ((2*2=4) \land (3*3=9)) \lor (\lnot(2*2=4)\land\lnot(3*3=9))
Для удобства построения таблицы истинности введем логические переменные.
Обозначим 2*2=4 через a, 3*3=9 - через b.
Тогда высказывание примет вид:
(a \land b) \lor (\lnot a\land\lnot b)
Для этого выражения и построим таблицу истинности.

2. Для доказательства равносильности указанных выражений можно построить таблицы истинности и сравнить их.
Как видно, НЕСОВПАДЕНИЕ полное, т.е. ни при каком сочетании a и b выражения не равносильны. Это подтверждается  теорией - имеются законы де-Моргана, в которых еще присутствует общее отрицание или в правой. или в левой части.
\bar a \lor \bar b = \overline{a \land b}
Сразу, у меня с информатикой плохо! и было бы неплохо, если вы напишите на листке : d 1. записать со
Сразу, у меня с информатикой плохо! и было бы неплохо, если вы напишите на листке : d 1. записать со
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота