vanо12
06.04.2022 11:43

Найди ошибки в записи программ: programm 4A BEGIN
Вася
{Петя}
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
poli143
05.03.2021 17:40
Var
x1, y1, x2, y2, x3, y3, a, b, c, p, s: real;
begin
readln(x1, y1, x2, y2, x3, y3);
a:=sqrt(sqr(abs(x1-x2))+sqr(abs(y1-y2)));
b:=sqrt(sqr(abs(x2-x3))+sqr(abs(y2-y3)));
c:=sqrt(sqr(abs(x1-x3))+sqr(abs(y1-y3)));
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
if s=0 then write('Лежат на одной прямой') else write('Не лежат на одной прямой');
end.

Объясняю. Образуем из этих трёх точек треугольник. a, b, c - стороны треугольника. p - полу-периметр треугольника. s - площадь треугольника. Площадь вычисляется по формуле Герона. Если площадь равна нуля, значит точки лежат на одной прямой. Если нет - не лежат. 
0,0(0 оценок)
Ответ:
yaya4
10.08.2022 16:12
1. Язык программирования Pascal создал:
a. Н. Вирт

2. Линейная структура построения программы подразумевает
b. Последовательное выполнение всех элементов программы

3. Оператор присваивания имеет вид:
b. :=

4. Команда CLRSCR служит для
c. очистки экрана

5. раздел VAR служит
a. Для описания используемых переменных

6. Переменные – это:
a. величины, которые могут менять свое значение в процессе выполнения программы

7. Правильная строковая запись выражения
b. x-x*x*x/abs (x) +sin (x)
Так как скобки там не на что не влияют, то их отсутствие правильный вариант в отличае от пункта с
Пункт а тоже может быть верным в языке где степень определена как ***, например в Ruby это **. Без указания языка/универсальным будет ответ b

8. целочисленное деление можно выразить следующей функцией:
b. A div B

9. математическое выражение х2-7х+6 можно записать:
x*x-7*x+6

10. выражение на паскале (abs (x)-abs(y))/(1 + abs (1/s)) можно записать:
 (|x|-|y|)/(1+|1/s|)

11. раздел операторов начинается служебным словом:
c. BEGIN

12. ввод данных с клавиатуры осуществляется с оператора:
b. READ, READLN

13. вывод данных на экран осуществляется с оператора:
a. WRITE, WRITELN

14. чему будет равно значение переменной М в результате выполнения серии операторов
N:=5;
Y:=2;
M:=N/5+3*Y*N
M = 1+3*2*5=31

15. тип переменных REAL это:
d. верного ответа нет
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота