Элис6666666666
05.11.2022 01:21

Написать программу суммирования первых цифр вводимых двузначных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ru5829
29.09.2020 12:48
Функция isSevenHere возвращает истину, если в числе есть семерка, и ложь - если ее нет. В цикле for перебираем все значения от 1 до K (число, введенное с клавиатуры), и выводим на экран только те, где есть семерка.

Код программы:

function isSevenHere(number : integer) : boolean;var digit : integer;begin  Result := true;  while (number > 0) do  begin        digit := number mod 10;    if (digit = 7) then            exit;    number := number div 10;  end;  Result := false;end;
var i,k :integer;begin  write('Введите k: ');  readln(k);
  for i := 1 to k do    if (isSevenHere(i) = true) then      write(i,' ');end.
Найти и вывести на экран все целые числа из промежутка от 1 до k, в десятичной записи которых есть ц
0,0(0 оценок)
Ответ:
DarkLooord
02.07.2022 16:15

Program mathlover12;

const

 n = 6; {Количество элементов массива}

var  

 a:array[1..n] of integer;

s:string;

i,min,max: integer;

begin

 s:=' -=Alphaeus=- ';

 for i:=1 to 22 do begin write(s[i]); sleep(42) end;

{вводим элементы массива}

 writeln; writeln('Введите ',n,' чисел:');

 for i:=1 to n do read(a[i]);

{Ищем min и max}

min:=a[1];

max:=a[1];

 for i:=2 to n do

   begin

     if min>a[i] then min:=a[i];

     if max<a[i] then max:=a[i];

   end;

{Выводим произведение  min и max}

 writeln; writeln;

 writeln('Произведение min и max равнo ',min*max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота