charaX
04.05.2021 20:56

НА ПИТОНЕ!! Для определения местоположения объекта на Земном шаре используются географические координаты: широта (от -90° до 90°) и долгота (-180° до 180°).
Будем считать, что все города на Земле имеют целочисленные координаты: долготу от -180° до 179° и широту от -89° до 89° (будем считать, что на полюсах городов нет). Размером города будем пренебрегать, то есть будем считать, что город - это точка на Земле. И, конечно, в одной точке не может быть два разных города. В каждом городе живёт какое-то количество жителей.
Три правителя нашей планеты решили создать три страны, разделив между собой все города Земного шара. Границы своих владений они хотят проводить по меридианам, причем города, расположенные на граничном меридиане относятся к территории, расположенной правее этого меридиана, то есть в сторону увеличения долготы. Будем считать, что меридиан с долготой -180° правее меридиана с долготой 179°.
Для справедливости они хотят разделить все города так, чтобы количество жителей в наиболее населённой стране отличалось от количества жителей в наименее населённой стране минимально.
Исходные данные
В первой строке записано целое число n (1 ≤ n ≤ 64440) – количество городов на планете. Каждая из следующих n строк содержит описание i-го города в виде тройки чисел: широта X (-89 ≤ X ≤ 89), долгота Y (-180 ≤ Y ≤ 179), численность P (1 ≤ P ≤ 100000).
Результат
Выведите одно целое число - минимальную разность между наиболее населенной и наименее населенной страной, которой можно добиться, разделяя города указанным выше
Пример
исходные данные результат
6 380
57 -15 70
42 -110 80
-12 171 10
75 -82 500
-32 23 50
44 -54 50

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
roxolanavarLana
21.08.2022 14:06

PascalABC.NET

begin

 var n := ReadInteger('n =');

 var a := ArrRandom(n, -99, 99);

 a.Println;

 Println('Результат:', (a.Max + a.Min) / 2)

end.

Turbo Pascal

program abcd;

uses Crt;

const

 nn = 100;

var

 i, n, max, min: integer;

 a: array[1..nn] of integer;

 

begin

 ClrScr;

 Write('n = ');

 Readln(n);

 Randomize;

 max := -32768;

 min := 32767;

 for i := 1 to n do

 begin

   a[i] := Random(199) - 99;

   Write(a[i], ' ');

   if a[i] > max then

     max := a[i]

   else if a[i] < min then

     min := a[i]

 end;

 Writeln;

 Writeln('Результат: ', (max + min) / 2);

 ReadKey

end.

0,0(0 оценок)
Ответ:
yuostroi
21.08.2022 14:06

Бобби Дик, Пуффендуй (около 20480 слов)

Что такое прорицание?

Задача этой науки заключается в предсказании или предугадывании грядущих

событий, которые уже существуют на планах космических и кармических

закономерностей.

Гадание (divination) - предсказание будущего, поиск пропавших объектов и

людей и установление виновности при информации, полученной из

каких-либо знамений, чар, снов, видений, а также с применением

специальных инструментов. С самого давнего времени во всех известных

цивилизациях люди обращались к сверхъестественным силам за и

советом в личных и государственных делах. В истории различают два вида

гадания: толкование природных явлений и интерпретация комбинаций

брошенных палочек, камней или костей. На протяжении долгой истории

гадание применялось для выявления преступников. Несмотря на особые

психологические прорицателей нередко наказанию подвергались

невинные люди.

Искусством гадания обладают ведьмы, волшебники, мудрецы, знахари, маги и

шаманы. В некоторых цивилизациях на протяжении всей их истории гаданием

занимался особый класс священнослужителей мужского или женского пола,

обладавших провидения и толкования знамений.

Наука пророков преподавалась всегда на высших ступенях всех древних

мистерий и была исключительным достоянием посвящённых жрецов. Это было

связано вовсе не с желанием обладать монополией в данной области, а с

высоким уровнем бытия, которого посвящённые добивались в этих тайных

школах, что и позволяло им вступать на планы, недоступные обычным

смертным.

Существовали, например, "Школы Пророков" в древней Палестине и Финикии,

которые имелись в городах Иерихон, Самария, Назарет, Вефин и др.

Руководили этими школами великие адепты-пророки. Их ученики, которых

называли "дети пророков", жили в условиях уединённой и суровой жизни с

постоянным обучением, молитвами, чтением Св. Писаний, медитацией.

Наконец, существовали храмы, принадлежавшие мистериям, в которых имелись

т. н. оракулы, отдельные жрецы или целые их коллегии, занимавшиеся

исключительно пророчествованием.

Так на острове Сен или Лиамбис близ Ушанта находилась коллегия

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота